aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 12:58:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-24 09:40:34 +0000
commitb54fa253104c6fec402f8b678337293589cc0545 (patch)
tree7708a32054230cad9f82d6f82daa32740fb849d3 /meta/recipes-extended
parentd47572d3dd7ac442bd18205e8f740f2542814a23 (diff)
downloadopenembedded-core-contrib-b54fa253104c6fec402f8b678337293589cc0545.tar.gz
pixz: Add 1.0.6
xz gives better compression results than bzip/gz but is often slower. Using parallel compression mitigates this somewhat and is particularly useful for the SDK. Whilst xz does have some parallel support, pixz appears to perform better and supports parallel decompression as well as a simpler command line. (From OE-Core rev: b65ab3a38093023310b2f17251b27471cf857561) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/pixz/pixz/936d8068ae19d95260d3058f41dd6cf718101cd6.patch68
-rw-r--r--meta/recipes-extended/pixz/pixz_1.0.6.bb24
2 files changed, 92 insertions, 0 deletions
diff --git a/meta/recipes-extended/pixz/pixz/936d8068ae19d95260d3058f41dd6cf718101cd6.patch b/meta/recipes-extended/pixz/pixz/936d8068ae19d95260d3058f41dd6cf718101cd6.patch
new file mode 100644
index 0000000000..e3489db5b8
--- /dev/null
+++ b/meta/recipes-extended/pixz/pixz/936d8068ae19d95260d3058f41dd6cf718101cd6.patch
@@ -0,0 +1,68 @@
+From 936d8068ae19d95260d3058f41dd6cf718101cd6 Mon Sep 17 00:00:00 2001
+From: Christian Krause <kizkizzbangbang@googlemail.com>
+Date: Sat, 26 Dec 2015 14:36:17 +0100
+Subject: [PATCH] option to not build man page
+
+fixes #56
+---
+ configure.ac | 23 +++++++++++++++++++----
+ src/Makefile.am | 2 ++
+ 2 files changed, 21 insertions(+), 4 deletions(-)
+
+Upstream-Status: Backport
+RP 2016/01/22
+
+diff --git a/configure.ac b/configure.ac
+index b437e56..4cb56bc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -20,13 +20,28 @@ AC_CHECK_FILE(
+ [src/pixz.1],
+ [],
+ [
+- AC_CHECK_PROG(A2X, a2x, a2x, [])
+- if test "x$A2X" = x ; then
+- AC_MSG_ERROR([AsciiDoc not found, not able to generate the man page.])
+- fi
++ AC_ARG_WITH(
++ [manpage],
++ [ --without-manpage don't build man page],
++ [case ${withval} in
++ yes) manpage=true ;;
++ no) manpage=false ;;
++ *) AC_MSG_ERROR([bad value ${withval} for --with-manpage]) ;;
++ esac],
++ [manpage=true]
++ )
+ ]
+ )
+
++AM_CONDITIONAL([MANPAGE], [test x$manpage = xtrue])
++
++if test x$manpage = xtrue ; then
++ AC_CHECK_PROG(A2X, a2x, a2x, [])
++ if test "x$A2X" = x ; then
++ AC_MSG_ERROR([AsciiDoc not found, not able to generate the man page.])
++ fi
++fi
++
+ # Checks for libraries.
+ AC_CHECK_LIB([m], [ceil])
+ AX_PTHREAD
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 600ec90..b98f450 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -15,6 +15,7 @@ pixz_SOURCES = \
+ read.c \
+ write.c
+
++if MANPAGE
+ # TODO remove when possible: This is a hack because a2x is not able to output the man pages to a
+ # specific directory, only to where the source is.
+ pixz.1: pixz.1.asciidoc
+@@ -26,3 +27,4 @@ man_MANS = pixz.1
+ CLEANFILES = pixz.1
+
+ EXTRA_DIST = $(man_MANS) pixz.1.asciidoc
++endif
diff --git a/meta/recipes-extended/pixz/pixz_1.0.6.bb b/meta/recipes-extended/pixz/pixz_1.0.6.bb
new file mode 100644
index 0000000000..492b7ef611
--- /dev/null
+++ b/meta/recipes-extended/pixz/pixz_1.0.6.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Parallel, indexed xz compressor"
+
+DEPENDS = "xz libarchive"
+DEEPNDS_class-native = "xz-replacement-native libarchive-native"
+
+SRC_URI = "https://github.com/vasi/pixz/releases/download/v${PV}/${BPN}-${PV}.tar.xz"
+SRC_URI[md5sum] = "f6dc5909c9a31b192f69aa397ae8df48"
+SRC_URI[sha256sum] = "02c50746b134fa1b1aae41fcc314d7c6f1919b3d48bcdea01bf11769f83f72e8"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5cf6d164086105f1512ccb81bfff1926"
+
+SRC_URI += "file://936d8068ae19d95260d3058f41dd6cf718101cd6.patch"
+
+EXTRA_OECONF += "--without-manpage"
+
+CACHED_CONFIGUREVARS += "ac_cv_file_src_pixz_1=no"
+
+inherit autotools pkgconfig
+
+PKG_CONFIG_PATH_append_class-native = ":${STAGING_DIR_HOST}${libdir}/xz-native/pkgconfig"
+BUILD_LDFLAGS_append_class-native = " -Wl,-rpath,${STAGING_DIR_HOST}${libdir}/xz-native/"
+
+BBCLASSEXTEND = "native"