summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorAndreas Obergschwandtner <andreas.obergschwandtner@skidata.com>2019-08-05 16:35:55 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-07 16:08:08 +0100
commitbeb4fb0b0e89ce6b80645322ee435a6b4909b652 (patch)
tree3a9711b1f381765c1529bb467736d314ebd8b18a /meta/recipes-extended
parenta44e40675e151eb079d7d9e87e734ca5cfb923b5 (diff)
downloadopenembedded-core-contrib-beb4fb0b0e89ce6b80645322ee435a6b4909b652.tar.gz
bzip2: set the autoconf package version to the recipe version
This is done to require only a single version change if bzip2 is updated and fixes also setting package version 1.0.6 for bzip2 1.0.8. Signed-off-by: Andreas Obergschwandtner <andreas.obergschwandtner@skidata.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/bzip2/bzip2/configure.ac2
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.8.bb4
2 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2/configure.ac b/meta/recipes-extended/bzip2/bzip2/configure.ac
index e2bf1bf110..b8abade2d9 100644
--- a/meta/recipes-extended/bzip2/bzip2/configure.ac
+++ b/meta/recipes-extended/bzip2/bzip2/configure.ac
@@ -1,6 +1,6 @@
AC_PREREQ([2.57])
-AC_INIT(bzip2, 1.0.6)
+AC_INIT(bzip2, %BZIP2_VERSION%)
AM_INIT_AUTOMAKE(foreign)
AM_MAINTAINER_MODE
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.8.bb b/meta/recipes-extended/bzip2/bzip2_1.0.8.bb
index 6f86b451ae..8e9b779e67 100644
--- a/meta/recipes-extended/bzip2/bzip2_1.0.8.bb
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.8.bb
@@ -29,6 +29,10 @@ ALTERNATIVE_${PN} = "bunzip2 bzcat bzip2"
#install binaries to bzip2-native under sysroot for replacement-native
EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}"
+do_configure_prepend () {
+ sed -i -e "s|%BZIP2_VERSION%|${PV}|" ${S}/configure.ac
+}
+
do_install_ptest () {
sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
}