summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-08 20:17:49 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-09 09:16:02 -0800
commitfa3180007502affabbe57cb6366be18fbb9e94f8 (patch)
tree81fe711f1113e8bbd8a6429564175b2557578aba /meta/recipes-extended
parent994e43acc67efeb33d859be071609daa844e9b77 (diff)
downloadopenembedded-core-contrib-fa3180007502affabbe57cb6366be18fbb9e94f8.tar.gz
parted: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/parted/files/no_check.patch10
-rw-r--r--meta/recipes-extended/parted/files/syscalls.patch12
2 files changed, 11 insertions, 11 deletions
diff --git a/meta/recipes-extended/parted/files/no_check.patch b/meta/recipes-extended/parted/files/no_check.patch
index 58d8db4426..e6a26d11a5 100644
--- a/meta/recipes-extended/parted/files/no_check.patch
+++ b/meta/recipes-extended/parted/files/no_check.patch
@@ -5,12 +5,12 @@ it to be disabled.
RP - 4/11/08
-Index: parted-1.9.0/configure.ac
+Index: parted-3.2/configure.ac
===================================================================
---- parted-1.9.0.orig/configure.ac 2009-07-23 18:52:08.000000000 +0100
-+++ parted-1.9.0/configure.ac 2010-02-02 14:13:56.013905093 +0000
-@@ -477,7 +477,7 @@
- AM_CONDITIONAL([BUILD_LINUX], [test "$OS" = linux])
+--- parted-3.2.orig/configure.ac
++++ parted-3.2/configure.ac
+@@ -555,7 +555,7 @@ AC_CHECK_HEADER([execinfo.h], [
+ AM_CONDITIONAL([COMPILE_FOR_S390], [test "$host_cpu" = s390 || test "$host_cpu" = s390x])
dnl check for "check", unit testing library/header
-PKG_CHECK_MODULES([CHECK], [check >= 0.9.3], have_check=yes, have_check=no)
diff --git a/meta/recipes-extended/parted/files/syscalls.patch b/meta/recipes-extended/parted/files/syscalls.patch
index e9bbe9a956..93205a0a80 100644
--- a/meta/recipes-extended/parted/files/syscalls.patch
+++ b/meta/recipes-extended/parted/files/syscalls.patch
@@ -4,10 +4,10 @@ Upstream-Status: Pending
libparted/arch/linux.c | 13 +++++++++++++
1 file changed, 13 insertions(+)
-Index: parted-1.9.0/libparted/arch/linux.c
+Index: parted-3.2/libparted/arch/linux.c
===================================================================
---- parted-1.9.0.orig/libparted/arch/linux.c 2009-07-23 18:52:08.000000000 +0100
-+++ parted-1.9.0/libparted/arch/linux.c 2010-02-02 14:14:16.523904768 +0000
+--- parted-3.2.orig/libparted/arch/linux.c
++++ parted-3.2/libparted/arch/linux.c
@@ -17,6 +17,8 @@
#define PROC_DEVICES_BUFSIZ 16384
@@ -16,8 +16,8 @@ Index: parted-1.9.0/libparted/arch/linux.c
+
#include <config.h>
#include <arch/linux.h>
-
-@@ -1477,12 +1479,14 @@
+ #include <linux/blkpg.h>
+@@ -1696,12 +1698,14 @@ linux_refresh_close (PedDevice* dev)
#if SIZEOF_OFF_T < 8
@@ -32,7 +32,7 @@ Index: parted-1.9.0/libparted/arch/linux.c
loff_t
llseek (unsigned int fd, loff_t offset, unsigned int whence)
-@@ -1490,11 +1494,20 @@
+@@ -1709,11 +1713,20 @@ llseek (unsigned int fd, loff_t offset,
loff_t result;
int retval;