aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/builder/builder_0.1.bb
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2012-11-21 21:54:24 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-21 20:40:43 +0000
commit06124dbeafb8151a7927c9af88baf8e23fcca363 (patch)
treed144dc4437066a1652c240a3d1f6cde850b66d0f /meta/recipes-graphics/builder/builder_0.1.bb
parent76950d32f1a3426228df33855ba54b63027ce905 (diff)
downloadopenembedded-core-contrib-06124dbeafb8151a7927c9af88baf8e23fcca363.tar.gz
builder: fix adduser breakage with password
Build Appliance needs to have for the builder user a password set. However, the useradd.bbclass requires the last parameter to be the user's group name. Previously, the password was the last parameter to useradd command. Fixed using the right order for parameters. (From OE-Core rev: 29f2ae0305b9a3db9632a8fe078fedc88f89a9ad) Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/builder/builder_0.1.bb')
-rw-r--r--meta/recipes-graphics/builder/builder_0.1.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-graphics/builder/builder_0.1.bb b/meta/recipes-graphics/builder/builder_0.1.bb
index 41871d6f1b..78d41e578d 100644
--- a/meta/recipes-graphics/builder/builder_0.1.bb
+++ b/meta/recipes-graphics/builder/builder_0.1.bb
@@ -1,7 +1,7 @@
SUMMARY = "New user to do specific job"
DESCRIPTION = "This recipe create a new user named ${PN}, who is used for specific jobs like building. The task can be auto started via mini X"
SECTION = "x11"
-PR = "r5"
+PR = "r6"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://builder_hob_start.sh;endline=5;md5=84796c3c41785d86100fdabcbdade00e"
@@ -20,8 +20,8 @@ BUILDER_PASSWORD ?= ".gLibiNXn0P12"
USERADD_PACKAGES = "${PN}"
USERADD_PARAM_${PN} = "--system --create-home \
--groups video,tty,audio \
- --user-group ${PN} \
- --password ${BUILDER_PASSWORD}"
+ --password ${BUILDER_PASSWORD} \
+ --user-group ${PN}"
do_install () {
install -d -m 755 ${D}${sysconfdir}/mini_x/session.d