aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libva/libva_2.1.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-02-21 12:30:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-24 10:31:35 +0000
commitf8c01917594892be366580873618fa20272d2423 (patch)
tree468546fff6bd4360bc987a1806042208d577c4b5 /meta/recipes-graphics/libva/libva_2.1.0.bb
parent9e6d283aa9c77685f55a62fa220226d9149ecd7a (diff)
downloadopenembedded-core-contrib-f8c01917594892be366580873618fa20272d2423.tar.gz
libva: upgrade to 2.1.0
Major changes: * Bump VA-API version to 1.1.0 * Add API for multi-frame processing * Add entrypoint VAEntrypointStats for Statistics * Add data structures for HEVC FEI support * Add new attributes for decoding/encoding/video processing * Add new VPP filter for Total Color Correction * Add blending interface in VPP * Add rotation interface in VPP * Add mirroring interface in VPP * Add Chroma siting flags in VPP * Add new color standard definitions * Add new interface for exporting surface * Add message callbacks for drivers to use Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/libva/libva_2.1.0.bb')
-rw-r--r--meta/recipes-graphics/libva/libva_2.1.0.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libva/libva_2.1.0.bb b/meta/recipes-graphics/libva/libva_2.1.0.bb
new file mode 100644
index 0000000000..d3cf6334ce
--- /dev/null
+++ b/meta/recipes-graphics/libva/libva_2.1.0.bb
@@ -0,0 +1,46 @@
+SUMMARY = "Video Acceleration (VA) API for Linux"
+DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
+and API specification which enables and provides access to graphics \
+hardware (GPU) acceleration for video processing on Linux and UNIX \
+based operating systems. Accelerated processing includes video \
+decoding, video encoding, subpicture blending and rendering. The \
+specification was originally designed by Intel for its GMA (Graphics \
+Media Accelerator) series of GPU hardware, the API is however not \
+limited to GPUs or Intel specific hardware, as other hardware and \
+manufacturers can also freely use this API for hardware accelerated \
+video decoding."
+
+HOMEPAGE = "https://01.org/linuxmedia/vaapi"
+BUGTRACKER = "https://github.com/intel/libva/issues"
+
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
+
+SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2"
+
+SRC_URI[md5sum] = "9d6e4f1d36c407566343e9dde5a972b8"
+SRC_URI[sha256sum] = "f3fa953a11d3210c3a4ee79031abdbe0863d5ce13d9b3f93f315f1eec60a4b0f"
+
+UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
+
+DEPENDS = "libdrm virtual/mesa"
+
+inherit autotools pkgconfig distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "opengl"
+
+EXTRA_OECONF = "ac_cv_prog_WAYLAND_SCANNER=wayland-scanner"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
+PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
+PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"
+
+PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
+
+RDEPENDS_${PN}-x11 =+ "${PN}"
+RDEPENDS_${PN}-glx =+ "${PN}-x11"
+
+FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
+FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
+FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"