aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-app
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-04-12 10:59:51 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-12 16:32:30 +0100
commit3a4ce4bd2b1ab7834edabbaf63acb18113cf1907 (patch)
tree6f2b0e52a3f9652173f75863b3baa90fc6a2d6b5 /meta/recipes-graphics/xorg-app
parent3f501204f375cc40a14597a25cb09faaba9ff802 (diff)
downloadopenembedded-core-contrib-3a4ce4bd2b1ab7834edabbaf63acb18113cf1907.tar.gz
xmodmap: fix compile with gcc 4.8
With gcc 4.8 there are compile errors: xmodmap.c:289:5: error: implicit declaration of function 'asprintf' [-Werror=implicit-function-declaration] (and more) These have been fixed upstream so take the patch from git until 1.0.8 is released. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-app')
-rw-r--r--meta/recipes-graphics/xorg-app/xmodmap/gnu-source.patch60
-rw-r--r--meta/recipes-graphics/xorg-app/xmodmap_1.0.7.bb2
2 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-app/xmodmap/gnu-source.patch b/meta/recipes-graphics/xorg-app/xmodmap/gnu-source.patch
new file mode 100644
index 0000000000..84bd973764
--- /dev/null
+++ b/meta/recipes-graphics/xorg-app/xmodmap/gnu-source.patch
@@ -0,0 +1,60 @@
+Upstream-Status: Backport
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From 42f99a7a7b836f6f9704a7b1747eb722c93446ec Mon Sep 17 00:00:00 2001
+From: Alan Coopersmith <alan.coopersmith@oracle.com>
+Date: Mon, 23 Apr 2012 14:28:39 +0000
+Subject: include config.h before stdio.h & other system headers
+
+Ensures definitions like _GNU_SOURCE are visible when needed.
+
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net>
+---
+diff --git a/exec.c b/exec.c
+index dbcb669..419b10e 100644
+--- a/exec.c
++++ b/exec.c
+@@ -54,6 +54,10 @@ from The Open Group.
+ * original xmodmap, written by David Rosenthal, of Sun Microsystems.
+ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include <X11/Xos.h>
+ #include <X11/Xlib.h>
+ #include <stdio.h>
+diff --git a/pf.c b/pf.c
+index 0eb0f55..3f0c3f4 100644
+--- a/pf.c
++++ b/pf.c
+@@ -26,6 +26,10 @@ from The Open Group.
+
+ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include <X11/Xos.h>
+ #include <X11/Xlib.h>
+ #include <stdio.h>
+diff --git a/xmodmap.c b/xmodmap.c
+index 58a8e70..0f89629 100644
+--- a/xmodmap.c
++++ b/xmodmap.c
+@@ -26,6 +26,10 @@ from The Open Group.
+
+ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include <X11/Xos.h>
+ #include <X11/Xlib.h>
+ #include <stdio.h>
+--
+cgit v0.9.0.2-2-gbebe \ No newline at end of file
diff --git a/meta/recipes-graphics/xorg-app/xmodmap_1.0.7.bb b/meta/recipes-graphics/xorg-app/xmodmap_1.0.7.bb
index fab1b167e6..573eecbe58 100644
--- a/meta/recipes-graphics/xorg-app/xmodmap_1.0.7.bb
+++ b/meta/recipes-graphics/xorg-app/xmodmap_1.0.7.bb
@@ -14,5 +14,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=eef098b27f09d0ac39268df0cc2c00b5"
PR = "${INC_PR}.0"
PE = "1"
+SRC_URI += "file://gnu-source.patch"
+
SRC_URI[md5sum] = "d9b65f6881afe0d6d9863b30e1081bde"
SRC_URI[sha256sum] = "ef22ede9c4a3c720da539292c6911515a8408e618e0dec6aa2196ee2153de4b5"