aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorValentin Popa <valentin.popa@intel.com>2014-02-18 13:32:16 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-20 14:28:03 +0000
commita5ebdb6ad8e4f94ac819275d55575230e057e4ae (patch)
tree541c609e722797fe50700931978f54e2e1827d2e /meta/recipes-graphics
parente13741e52cc6b59757942a05c7847fe7fc090f63 (diff)
downloadopenembedded-core-contrib-a5ebdb6ad8e4f94ac819275d55575230e057e4ae.tar.gz
mesa: upgrade to 9.2.5
tested on qemux86, genericx86 for core-image-sato and core-image-weston. Signed-off-by: Valentin Popa <valentin.popa@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/mesa/mesa-gl_9.2.5.bb (renamed from meta/recipes-graphics/mesa/mesa-gl_9.2.2.bb)0
-rw-r--r--meta/recipes-graphics/mesa/mesa_9.2.2.bb11
-rw-r--r--meta/recipes-graphics/mesa/mesa_9.2.5.bb19
-rw-r--r--meta/recipes-graphics/mesa/mesa_git.bb12
4 files changed, 29 insertions, 13 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-gl_9.2.2.bb b/meta/recipes-graphics/mesa/mesa-gl_9.2.5.bb
index 21f6151f29..21f6151f29 100644
--- a/meta/recipes-graphics/mesa/mesa-gl_9.2.2.bb
+++ b/meta/recipes-graphics/mesa/mesa-gl_9.2.5.bb
diff --git a/meta/recipes-graphics/mesa/mesa_9.2.2.bb b/meta/recipes-graphics/mesa/mesa_9.2.2.bb
deleted file mode 100644
index 60eba01db1..0000000000
--- a/meta/recipes-graphics/mesa/mesa_9.2.2.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-require ${BPN}.inc
-
-SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
- file://0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch \
- file://0006-fix-out-of-tree-egl.patch \
- "
-
-SRC_URI[md5sum] = "20887f8020db7d1736a01ae9cd5d8c38"
-SRC_URI[sha256sum] = "c78a5035233672844cf2492fe82dc10877e12026be227d04469d6ca6ac656a3d"
-
-S = "${WORKDIR}/Mesa-${PV}"
diff --git a/meta/recipes-graphics/mesa/mesa_9.2.5.bb b/meta/recipes-graphics/mesa/mesa_9.2.5.bb
new file mode 100644
index 0000000000..737ed1a6cb
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_9.2.5.bb
@@ -0,0 +1,19 @@
+require ${BPN}.inc
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
+ file://0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch \
+ file://0006-fix-out-of-tree-egl.patch \
+ "
+
+SRC_URI[md5sum] = "9fb4de29ca1d9cfd03cbdefa123ba336"
+SRC_URI[sha256sum] = "b46ab9efed176df0591993397594d712ada9da6a47fd31bbe75050fe28eb6bf0"
+
+S = "${WORKDIR}/Mesa-${PV}"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@base_contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS/#if ${@base_contains('DISTRO_FEATURES', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}
diff --git a/meta/recipes-graphics/mesa/mesa_git.bb b/meta/recipes-graphics/mesa/mesa_git.bb
index 19d3e70823..0abedbcb83 100644
--- a/meta/recipes-graphics/mesa/mesa_git.bb
+++ b/meta/recipes-graphics/mesa/mesa_git.bb
@@ -5,8 +5,8 @@ DEFAULT_PREFERENCE = "-1"
LIC_FILES_CHKSUM = "file://docs/license.html;md5=f69a4626e9efc40fa0d3cc3b02c9eacf"
PR = "${INC_PR}.0"
-SRCREV = "8f0742051e8501e737affb392996aef172034ca8"
-PV = "9.2.2+git${SRCPV}"
+SRCREV = "4636e87191fddd492ed8c61ba61faf4b2d89b2e4"
+PV = "9.2.5+git${SRCPV}"
SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa \
file://0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch \
@@ -14,3 +14,11 @@ SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa \
"
S = "${WORKDIR}/git"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@base_contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS/#if ${@base_contains('DISTRO_FEATURES', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}