aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-07 10:49:59 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-07 14:44:25 +0000
commitad9bd9ce164c9cb1212de27fec84ad0fe5214bb2 (patch)
tree258ccbcb4256fa7b2df4d636430b4d9af70216c7 /meta/recipes-graphics
parentd87585385bfe00dd5e7448ae7d5bc5dc7f9ac782 (diff)
downloadopenembedded-core-contrib-ad9bd9ce164c9cb1212de27fec84ad0fe5214bb2.tar.gz
wayland: Add target sysroot scanner m4 macro
With the new aclocals process, accesses to the macros is a lot stricter and the native macros are not used. We need to ensure the modified macros are used in target builds to get the correct scanner functionality. Inserting the native macro into the target is the correct thing to do in this case. This resolves build failures in libva. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.4.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.4.0.bb b/meta/recipes-graphics/wayland/wayland_1.4.0.bb
index 0f08cacfea..604b7f4c54 100644
--- a/meta/recipes-graphics/wayland/wayland_1.4.0.bb
+++ b/meta/recipes-graphics/wayland/wayland_1.4.0.bb
@@ -34,3 +34,7 @@ do_install_append_class-native() {
-e 's,$PKG_CONFIG,pkg-config-native,g' \
-i ${D}/${datadir}/aclocal/wayland-scanner.m4
}
+
+sysroot_stage_all_append_class-target () {
+ cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
+}