summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-04-19 11:02:23 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-20 13:56:31 +0100
commit1533d913af0aac5524d2f9ebacaeafb5891124e2 (patch)
treeb0c9fc384cb7abfb0bde49091de68f4dfc0d49f3 /meta/recipes-graphics
parent3e588abaa081b2de238bbeead867204ff485e5ba (diff)
downloadopenembedded-core-contrib-1533d913af0aac5524d2f9ebacaeafb5891124e2.tar.gz
xwayland: add a standalone recipe
Please see here for the rationale for splitting XWayland out of main xserver-xorg tree: https://fedoraproject.org/wiki/Changes/XwaylandStandalone Release announcement: https://lists.x.org/archives/xorg-announce/2021-March/003076.html Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xwayland/xwayland_21.1.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xwayland/xwayland_21.1.1.bb b/meta/recipes-graphics/xwayland/xwayland_21.1.1.bb
new file mode 100644
index 0000000000..82765cdaf9
--- /dev/null
+++ b/meta/recipes-graphics/xwayland/xwayland_21.1.1.bb
@@ -0,0 +1,21 @@
+SUMMARY = "XWayland is an X Server that runs under Wayland."
+DESCRIPTION = "XWayland is an X Server running as a Wayland client, \
+and thus is capable of displaying native X11 client applications in a \
+Wayland compositor environment. The goal of XWayland is to facilitate \
+the transition from X Window System to Wayland environments, providing \
+a way to run unported applications in the meantime."
+HOMEPAGE = "https://fedoraproject.org/wiki/Changes/XwaylandStandalone"
+
+LICENSE = "MIT-X"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5df87950af51ac2c5822094553ea1880"
+
+SRC_URI = "https://www.x.org/archive/individual/xserver/xwayland-${PV}.tar.xz"
+SRC_URI[sha256sum] = "31f261ce51bbee76a6ca3ec02aa367ffa2b5efa2b98412df57ccefd7a19003ce"
+
+inherit meson features_check
+REQUIRED_DISTRO_FEATURES = "x11"
+
+DEPENDS += "xorgproto xtrans pixman libxkbfile libxfont2 wayland wayland-native wayland-protocols libdrm libepoxy"
+
+FILES_${PN} += "${libdir}/xorg/protocol.txt"
+