aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/cryptodev/cryptodev-tests_1.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2014-04-10 13:55:28 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-29 13:42:13 +0100
commit7c58b852f21588b2763a1b90d8f3cf2f31a868e2 (patch)
tree1622b6b533cdd1df5da3e610d0fd685c48f9baff /meta/recipes-kernel/cryptodev/cryptodev-tests_1.6.bb
parenta0930e6dfabc32a0f1f116a9de05c2b4b3b3a216 (diff)
downloadopenembedded-core-contrib-7c58b852f21588b2763a1b90d8f3cf2f31a868e2.tar.gz
cryptodev-tests: recipe for cryptodev test suite based on OpenSSL
(From OE-Core rev: c54fa061da6195081cd29817a351a36377b58e53) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/cryptodev/cryptodev-tests_1.6.bb')
-rw-r--r--meta/recipes-kernel/cryptodev/cryptodev-tests_1.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-kernel/cryptodev/cryptodev-tests_1.6.bb b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.6.bb
new file mode 100644
index 0000000000..efc41ae427
--- /dev/null
+++ b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.6.bb
@@ -0,0 +1,23 @@
+require cryptodev_${PV}.inc
+
+SUMMARY = "A test suite for /dev/crypto device driver"
+
+DEPENDS += "openssl"
+
+SRC_URI += " \
+file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
+file://0002-Fix-tests-Makefile-usage-of-LDLIBS-vs.-LDFLAGS.patch \
+"
+
+EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
+
+do_compile() {
+ oe_runmake testprogs
+}
+
+do_install() {
+ oe_runmake install_tests
+}
+
+FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
+FILES_${PN} = "${bindir}/tests_cryptodev/*"