aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/dtc
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2011-11-01 12:37:36 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-07 14:05:37 +0000
commit35574646e73da6c73173512124f58ca81d3e7c64 (patch)
tree88c2f18bdff1b6f0e7ab1aa95824887ccb1509dd /meta/recipes-kernel/dtc
parentf7196be455c11cd7f0aa6442ba5dcb64c66e9769 (diff)
downloadopenembedded-core-contrib-35574646e73da6c73173512124f58ca81d3e7c64.tar.gz
dtc: update to latest git version
Also remove patches that are no longer needed, as well as use the installation that is provided by the Makefile. Put all the extra stuff in a new dtc-misc package (From OE-Core rev: 43213fd610da7b550e6d738e224b49004776f799) Signed-off-by: Matthew McClintock <msm@freescale.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/dtc')
-rw-r--r--meta/recipes-kernel/dtc/dtc.inc12
-rw-r--r--meta/recipes-kernel/dtc/dtc/fix_for_compilation_with_gcc_4.6.0.patch51
-rw-r--r--meta/recipes-kernel/dtc/dtc/remove_space_opt.patch18
-rw-r--r--meta/recipes-kernel/dtc/dtc_git.bb10
4 files changed, 9 insertions, 82 deletions
diff --git a/meta/recipes-kernel/dtc/dtc.inc b/meta/recipes-kernel/dtc/dtc.inc
index eae46ac2d7..0f45d5f08e 100644
--- a/meta/recipes-kernel/dtc/dtc.inc
+++ b/meta/recipes-kernel/dtc/dtc.inc
@@ -6,13 +6,13 @@ DEPENDS = "flex-native bison-native"
inherit autotools
-do_install() {
- install -m 0755 -d ${D}${bindir}
- install -m 755 dtc ${D}${bindir}/dtc
-}
SRC_URI = "git://www.jdl.com/software/dtc.git;protocol=git \
- file://fix_for_compilation_with_gcc_4.6.0.patch"
+ "
-INC_PR = "r0"
+EXTRA_OEMAKE='PREFIX="${prefix}"'
+INC_PR = "r1"
S = "${WORKDIR}/git"
+
+PACKAGES =+ "${PN}-misc"
+FILES_${PN}-misc = "${bindir}/convert-dtsv0 ${bindir}/ftdump ${bindir}/dtdiff"
diff --git a/meta/recipes-kernel/dtc/dtc/fix_for_compilation_with_gcc_4.6.0.patch b/meta/recipes-kernel/dtc/dtc/fix_for_compilation_with_gcc_4.6.0.patch
deleted file mode 100644
index b34894d926..0000000000
--- a/meta/recipes-kernel/dtc/dtc/fix_for_compilation_with_gcc_4.6.0.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-Upstream-Status: Pending
-
-Fix following compilation errors with gcc 4.6.0
-| dtc.c: In function 'main':
-| dtc.c:100:17: error: variable 'check' set but not used [-Werror=unused-but-set-variable]
-| cc1: all warnings being treated as errors
-|
-| make: *** [dtc.o] Error 1
-| make: *** Waiting for unfinished jobs....
-| flattree.c: In function 'flat_read_mem_reserve':
-| flattree.c:700:14: error: variable 'p' set but not used [-Werror=unused-but-set-variable]
-| cc1: all warnings being treated as errors
-|
-| make: *** [flattree.o] Error 1
-| ERROR: oe_runmake failed
-
-Nitin A Kamble <nitin.a.kamble@intel.com> 2011/05/10
-
-Index: git/dtc.c
-===================================================================
---- git.orig/dtc.c
-+++ git/dtc.c
-@@ -97,7 +97,7 @@ int main(int argc, char *argv[])
- const char *inform = "dts";
- const char *outform = "dts";
- const char *outname = "-";
-- int force = 0, check = 0;
-+ int force = 0, __attribute__((__unused__)) check = 0;
- const char *arg;
- int opt;
- FILE *outf = NULL;
-Index: git/flattree.c
-===================================================================
---- git.orig/flattree.c
-+++ git/flattree.c
-@@ -697,7 +697,6 @@ static struct reserve_info *flat_read_me
- {
- struct reserve_info *reservelist = NULL;
- struct reserve_info *new;
-- const char *p;
- struct fdt_reserve_entry re;
-
- /*
-@@ -706,7 +705,6 @@ static struct reserve_info *flat_read_me
- *
- * First pass, count entries.
- */
-- p = inb->ptr;
- while (1) {
- flat_read_chunk(inb, &re, sizeof(re));
- re.address = fdt64_to_cpu(re.address);
diff --git a/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch b/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch
deleted file mode 100644
index 8c26deca35..0000000000
--- a/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Remove the -Os flag
-
-Upstream-Status: Inappropriate [configuration]
-
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile
-+++ git/Makefile
-@@ -18,7 +18,7 @@ CONFIG_LOCALVERSION =
- CPPFLAGS = -I libfdt
- WARNINGS = -Werror -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
- -Wstrict-prototypes -Wmissing-prototypes
--CFLAGS = -g -Os -fPIC -Werror $(WARNINGS)
-+CFLAGS = -g -fPIC -Werror $(WARNINGS)
-
- BISON = bison
- LEX = flex
diff --git a/meta/recipes-kernel/dtc/dtc_git.bb b/meta/recipes-kernel/dtc/dtc_git.bb
index e010488dd8..c205de7023 100644
--- a/meta/recipes-kernel/dtc/dtc_git.bb
+++ b/meta/recipes-kernel/dtc/dtc_git.bb
@@ -3,14 +3,10 @@ require dtc.inc
LIC_FILES_CHKSUM = "file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
file://libfdt/libfdt.h;beginline=3;endline=52;md5=fb360963151f8ec2d6c06b055bcbb68c"
-SRCREV = "73dca9ae0b9abe6924ba640164ecce9f8df69c5a"
+SRCREV = "033089f29099bdfd5c2d6986cdb9fd07b16cfde0"
PV = "1.3.0+git${SRCPV}"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
S = "${WORKDIR}/git"
-SRC_URI_PATCH = " file://remove_space_opt.patch"
-SRC_URI_PATCH_virtclass-native = ""
-SRC_URI += "${SRC_URI_PATCH}"
-
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"