aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2016-01-20 16:39:30 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 23:42:36 +0000
commit4b4bb1e905cc20462f4fbc1105ac3fac7af93b15 (patch)
treeb6fbb0470c2cb3a9a871f98146fa86e67d6100b2 /meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb
parent55e263c559098cce99d8c3ef57ccc39f1d4a6848 (diff)
downloadopenembedded-core-contrib-4b4bb1e905cc20462f4fbc1105ac3fac7af93b15.tar.gz
kexec-tools: inherit update-rc.d
init script kdump is added, so inherit update-rc.d Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb')
-rw-r--r--meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb b/meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb
index 717376703f..866441b531 100644
--- a/meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb
+++ b/meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb
@@ -22,6 +22,12 @@ FILES_kexec = "${sbindir}/kexec"
FILES_kdump = "${sbindir}/kdump"
FILES_vmcore-dmesg = "${sbindir}/vmcore-dmesg"
+inherit update-rc.d
+
+INITSCRIPT_PACKAGES = "kdump"
+INITSCRIPT_NAME_kdump = "kdump"
+INITSCRIPT_PARAMS_kdump = "start 56 2 3 4 5 . stop 56 0 1 6 ."
+
do_install_append () {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/kdump ${D}${sysconfdir}/init.d/kdump