aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2013-10-01 22:54:40 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-07 09:37:31 +0100
commit17b5f2f16256c9e8c551416a8b7211e44dfa5e91 (patch)
tree0d3086c6148de85a731e69e70ab5f35c308b2ffe /meta/recipes-kernel/kmod
parent56ea7aca3e6b4a0db3f699cc0d775d267b36e164 (diff)
downloadopenembedded-core-contrib-17b5f2f16256c9e8c551416a8b7211e44dfa5e91.tar.gz
kmod: ptest fixes
Make kmod-ptest able to compile with separated source and build dir. Since kmod test files contain kernel modules for many different architectures, strip and arch gets confused and throws errors. (From OE-Core rev: 61cb45869caaed6578a217effaa72d247395d078) Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Björn Stenberg <bjst@enea.com> Signed-off-by: Maxin B. John <maxin.john@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/kmod')
-rw-r--r--meta/recipes-kernel/kmod/kmod/ptest.patch8
-rwxr-xr-xmeta/recipes-kernel/kmod/kmod/run-ptest4
-rw-r--r--meta/recipes-kernel/kmod/kmod_git.bb6
3 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-kernel/kmod/kmod/ptest.patch b/meta/recipes-kernel/kmod/kmod/ptest.patch
index c6479b2fb5..831dbcb909 100644
--- a/meta/recipes-kernel/kmod/kmod/ptest.patch
+++ b/meta/recipes-kernel/kmod/kmod/ptest.patch
@@ -15,10 +15,10 @@ diff -ruN a/Makefile.am b/Makefile.am
+ @for file in $(TESTSUITE); do \
+ install $$file $(DESTDIR)/testsuite; \
+ done;
-+ @cp Makefile $(DESTDIR)
-+ @sed -i 's/^Makefile/_Makefile/' ${DESTDIR}/Makefile
-+ @tar -czf $(DESTDIR)/tools.tgz $(noinst_SCRIPTS) $(noinst_PROGRAMS)
-+ @tar -C testsuite -czf $(DESTDIR)/testsuite.tgz rootfs-pristine .libs
++ @sed -e 's/^Makefile/_Makefile/' < Makefile > $(DESTDIR)/Makefile
++ @$(MKDIR_P) $(DESTDIR)/tools
++ @cp $(noinst_SCRIPTS) $(noinst_PROGRAMS) $(DESTDIR)/tools
++ @cp -r testsuite/rootfs testsuite/.libs $(DESTDIR)/testsuite
+
# ------------------------------------------------------------------------------
# custom release helpers
diff --git a/meta/recipes-kernel/kmod/kmod/run-ptest b/meta/recipes-kernel/kmod/kmod/run-ptest
index fac24fd6e1..37adec3d2f 100755
--- a/meta/recipes-kernel/kmod/kmod/run-ptest
+++ b/meta/recipes-kernel/kmod/kmod/run-ptest
@@ -1,5 +1,3 @@
#!/bin/sh
-tar -xzf tools.tgz
-tar -C testsuite -xzf testsuite.tgz
-make rootfs
+touch testsuite/stamp-rootfs
make -k runtest-TESTS 2>/dev/null| grep -e ^PASS -e ^FAIL
diff --git a/meta/recipes-kernel/kmod/kmod_git.bb b/meta/recipes-kernel/kmod/kmod_git.bb
index b07c06e7b4..ebecbcc82e 100644
--- a/meta/recipes-kernel/kmod/kmod_git.bb
+++ b/meta/recipes-kernel/kmod/kmod_git.bb
@@ -41,10 +41,12 @@ do_compile_prepend() {
}
do_compile_ptest () {
- oe_runmake buildtest-TESTS
- oe_runmake rootfs
+ oe_runmake buildtest-TESTS rootfs
}
+INHIBIT_PACKAGE_STRIP = "${@base_contains("DISTRO_FEATURES", "ptest", "1", "0", d)}"
+INSANE_SKIP_${PN}-ptest = "arch"
+
inherit update-alternatives
ALTERNATIVE_PRIORITY = "60"