summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/kernel-devsrc.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@xilinx.com>2020-01-28 17:14:10 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-03 00:09:59 +0000
commit1be199f79479d9c8125bd3548cd4f2354f597640 (patch)
tree6c50a4daf35b987be49cad10f6fa4dfa41a6ad37 /meta/recipes-kernel/linux/kernel-devsrc.bb
parent240e0ae13d35469eecafc82d2cd9cfd110095c55 (diff)
downloadopenembedded-core-contrib-1be199f79479d9c8125bd3548cd4f2354f597640.tar.gz
kernel-devsrc: update to v5.4+
To support on-target module building, we need to include syscall.tbl for ARM64 (just like we do for other architectures). We also copy .config with -a to ensure that we don't trigger extra processing and regen configs. Signed-off-by: Bruce Ashfield <bruce.ashfield@xilinx.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/kernel-devsrc.bb')
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index b6f2dbc2b0..2fa4be67cc 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -78,7 +78,7 @@ do_install() {
cp Module.markers $kerneldir/build
fi
- cp .config $kerneldir/build
+ cp -a .config $kerneldir/build
# This scripts copy blow up QA, so for now, we require a more
# complex 'make scripts' to restore these, versus copying them
@@ -128,11 +128,12 @@ do_install() {
# extra files, just in case
cp -a --parents tools/objtool/* $kerneldir/build/
- cp -a --parents tools/lib/str_error_r.c $kerneldir/build/
- cp -a --parents tools/lib/string.c $kerneldir/build/
+ cp -a --parents tools/lib/* $kerneldir/build/
cp -a --parents tools/lib/subcmd/* $kerneldir/build/
cp -a --parents tools/include/* $kerneldir/build/
+
+ cp -a --parents $(find tools/arch/${ARCH}/ -type f) $kerneldir/build/
fi
if [ "${ARCH}" = "arm64" ]; then
@@ -186,6 +187,7 @@ do_install() {
# required for generate missing syscalls prepare phase
cp -a --parents $(find arch/x86 -type f -name "syscall_32.tbl") $kerneldir/build
+ cp -a --parents $(find arch/arm -type f -name "*.tbl") $kerneldir/build
if [ "${ARCH}" = "x86" ]; then
# files for 'make prepare' to succeed with kernel-devel