summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/kernel-devsrc.bb
diff options
context:
space:
mode:
authorBeniamin Sandu <beniaminsandu@gmail.com>2019-04-11 10:28:54 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-11 21:19:27 +0100
commit68b9243729ac1982c9f1d30980cf979267bbc7c3 (patch)
tree25b8f59f7ac75d93e633a9e4858b9356aa6215ca /meta/recipes-kernel/linux/kernel-devsrc.bb
parent46f47b700ef7f58c8095db9bd3b4b867a6447360 (diff)
downloadopenembedded-core-contrib-68b9243729ac1982c9f1d30980cf979267bbc7c3.tar.gz
kernel-devsrc: check for localversion files in the kernel source tree
The kernel-devsrc rework doesn't take into account localversion files in the kernel source tree. This might result in modules with an incomplete version magic when building out-of-tree using the SDK. Before: root@qemux86:~# insmod hello.ko [ 42.000212] hello: version magic '5.0.3-yocto-standard SMP preempt mod_unload PENTIUMM ' should be '5.0.3-my-custom-release-yocto-standard SMP preempt mod_unload PENTIUMM ' [ 42.008200] hello: version magic '5.0.3-yocto-standard SMP preempt mod_unload PENTIUMM ' should be '5.0.3-my-custom-release-yocto-standard SMP preempt mod_unload PENTIUMM ' insmod: can't insert 'hello.ko': invalid module format After: root@qemux86:~# insmod hello.ko [ 39.094288] hello: loading out-of-tree module taints kernel. [ 39.108044] Hello World! Signed-off-by: Beniamin Sandu <beniamin.sandu@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/kernel-devsrc.bb')
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index 69a8eaef81..5ec5929735 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -228,6 +228,9 @@ do_install() {
# required to build scripts/selinux/genheaders/genheaders
cp -a --parents security/selinux/include/* $kerneldir/build/
+
+ # copy any localversion files
+ cp -a localversion* $kerneldir/build/ 2>/dev/null || :
)
# Make sure the Makefile and version.h have a matching timestamp so that