summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-dev.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-12-05 14:31:55 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-14 09:09:34 +0000
commit5877781d1dcb2883d00097b66ff2481a4a5ff930 (patch)
tree28d6b42540416a9863a0532cf4394d940429a9f2 /meta/recipes-kernel/linux/linux-yocto-dev.bb
parent34430ecdc4bb7414ca865df1b164bce1e4fec6fa (diff)
downloadopenembedded-core-contrib-5877781d1dcb2883d00097b66ff2481a4a5ff930.tar.gz
linux-yocto-dev: allow static SRCREVs via include
The linux-yocto dev recipe is intended to track the latest revisions of the kernel tree by default. To control revision churn, and integrate into a regular build schedule having the ability to specify a set of SRCREVs without modifying the recipe itself is desired. So we introduce an optional include file, and variables that control whether or not the static SRCREVs are used: USE_MACHINE_AUTOREV and USE_META_AUTOREV, to add this flexibility. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-dev.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-dev.bb25
1 files changed, 18 insertions, 7 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index e7b8d8b2a7..e8d14b966d 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -11,6 +11,12 @@
inherit kernel
require recipes-kernel/linux/linux-yocto.inc
+USE_MACHINE_AUTOREV ?= "1"
+USE_META_AUTOREV ?= "1"
+
+# provide this .inc to set specific revisions
+include recipes-kernel/linux/linux-yocto-dev-revisions.inc
+
KBRANCH = "standard/base"
KBRANCH_DEFAULT = "${KBRANCH}"
KMETA = "meta"
@@ -22,15 +28,19 @@ SRC_URI = "git://git.pokylinux.org/linux-yocto-dev.git;nocheckout=1;branch=${KBR
# linux-yocto-dev is the preferred provider, they will be overridden to
# AUTOREV in following anonymous python routine and resolved when the
# variables are finalized.
-SRCREV_machine="29594404d7fe73cd80eaa4ee8c43dcc53970c60e"
-SRCREV_meta="29594404d7fe73cd80eaa4ee8c43dcc53970c60e"
+SRCREV_machine ?= "29594404d7fe73cd80eaa4ee8c43dcc53970c60e"
+SRCREV_meta ?= "29594404d7fe73cd80eaa4ee8c43dcc53970c60e"
python () {
if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-dev":
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-dev to enable it")
else:
- d.setVar("SRCREV_machine", "${AUTOREV}")
- d.setVar("SRCREV_meta", "${AUTOREV}")
+ # if the revisions have been changed from the defaults above we leave them
+ # alone. But if the defaults are left, we change to AUTOREV.
+ if d.getVar("USE_MACHINE_AUTOREV", True) == "1":
+ d.setVar("SRCREV_machine", "${AUTOREV}")
+ if d.getVar("USE_META_AUTOREV", True) == "1":
+ d.setVar("SRCREV_meta", "${AUTOREV}")
}
LINUX_VERSION ?= "3.10+"
@@ -40,8 +50,9 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64)"
# Functionality flags
-KERNEL_FEATURES_append = " features/netfilter/netfilter.scc"
-KERNEL_FEATURES_append_qemux86=" cfg/sound.scc"
+KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
+KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
+KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
-KERNEL_FEATURES_append_qemux86=" cfg/paravirt_kvm.scc"
KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"
+