aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-12-22 09:49:20 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-23 12:04:01 +0000
commite8a1f4ccb10af234af1f2cb6905c638992558556 (patch)
tree69f31ee673427c339547279646783743c84de2a1 /meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb
parent0f29bd2c267efcb0087d73c38202ba233af636fd (diff)
downloadopenembedded-core-contrib-e8a1f4ccb10af234af1f2cb6905c638992558556.tar.gz
kernel: introduce linux-yocto v4.9 recipes
Introducing the 4.9 kernel recipes. 4.9 will be a LTSI kernel, so we introduce these recipes with the intent that they'll replace 4.1 as the LTSI kernel, and other older kernels (i.e 4.4/4.8) once 4.9 shown to be stable. linux-yocto-tiny and linux-yocto-rt are also part of this commit, but are placeholders while we wait for their content to be available. They will build, but provide nothing above the standard kernel at the moment. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb
new file mode 100644
index 0000000000..62df631f35
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb
@@ -0,0 +1,25 @@
+KBRANCH ?= "standard/tiny/common-pc"
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+LINUX_VERSION ?= "4.9"
+
+KMETA = "kernel-meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
+
+SRCREV_machine ?= "617635e43afee1aaf98a8f8300596f7a112513c0"
+SRCREV_meta ?= "c56f2da94e4773ea25eebfd14200164ef21730a3"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.9.git;branch=${KBRANCH};name=machine \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"
+
+COMPATIBLE_MACHINE = "(qemux86$)"
+
+# Functionality flags
+KERNEL_FEATURES = ""
+
+KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"