summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-01-11 12:59:56 -0500
committerAnuj Mittal <anuj.mittal@intel.com>2022-01-17 10:33:05 +0800
commit21e36f6fcf85c34dc0884ddf86bb104df25429f6 (patch)
tree5eda00fa96782cc6986e6824b28f84f5c30168ff /meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
parentd9a8cfebd5801ff0baea05899549e6f9ad3d8e41 (diff)
downloadopenembedded-core-contrib-21e36f6fcf85c34dc0884ddf86bb104df25429f6.tar.gz
linux-yocto/5.10: update to v5.10.90
Updating linux-yocto/5.10 to the latest korg -stable release that comprises the following commits: d3e491a20d15 Linux 5.10.90 8c15bfb36a44 bpf: Add kconfig knob for disabling unpriv bpf by default d8a5b1377bf6 perf script: Fix CPU filtering of a script's switch events 2386e81a1d27 net: fix use-after-free in tw_timer_handler 34087cf96046 Input: spaceball - fix parsing of movement data packets 9f329d0d6c91 Input: appletouch - initialize work before device registration 2a4f551dec1a scsi: vmw_pvscsi: Set residual data length conditionally 1cb8444f3114 binder: fix async_free_space accounting for empty parcels a6e26251dd3a usb: mtu3: set interval of FS intr and isoc endpoint 3b6efe0b7ba0 usb: mtu3: fix list_head check warning f10b01c48f85 usb: mtu3: add memory barrier before set GPD's HWO 1c4ace3e6b85 usb: gadget: f_fs: Clear ffs_eventfd in ffs_data_clear. 1933fe8ce712 xhci: Fresco FL1100 controller should not have BROKEN_MSI quirk set. b8553330a077 drm/amdgpu: add support for IP discovery gc_info table v2 28863ffe21ff drm/amdgpu: When the VCN(1.0) block is suspended, powergating is explicitly enabled a0f3ac399ef5 uapi: fix linux/nfc.h userspace compilation errors 818c9e0a04df nfc: uapi: use kernel size_t to fix user-space builds 8d31cbab4c29 i2c: validate user data in compat ioctl 51c94d8fbd09 fsl/fman: Fix missing put_device() call in fman_port_probe 920932b20e0c net/ncsi: check for error return from call to nla_put_u32 610af55f9fbe selftests/net: udpgso_bench_tx: fix dst ip argument 78503589b1e0 net/mlx5e: Fix wrong features assignment in case of error 61146008087a ionic: Initialize the 'lif->dbid_inuse' bitmap b7c9a1427b32 igc: Fix TX timestamp support for non-MSI-X platforms e8a5988a85c7 net/smc: fix kernel panic caused by race of smc_sock 97c87c1db9ff net/smc: don't send CDC/LLC message if link not ready 99f19566b1c4 net/smc: improved fix wait on already cleared link e553265ea564 NFC: st21nfca: Fix memory leak in device probe and remove 8d70dc0eecf0 net: lantiq_xrx200: fix statistics of received bytes 7ef89bd1e8f1 net: ag71xx: Fix a potential double free in error handling paths 40d36186913b net: usb: pegasus: Do not drop long Ethernet frames a67becdaa8ad net/smc: fix using of uninitialized completions 769d14abd35e sctp: use call_rcu to free endpoint 13c1bf43b674 selftests: Calculate udpgso segment count without header adjustment abe74fb43378 udp: using datalen to cap ipv6 udp max gso segments 5e6ad649e927 net/mlx5e: Fix ICOSQ recovery flow for XSK 73665165b64a net/mlx5e: Wrap the tx reporter dump callback to extract the sq 4cd1da02f0c3 net/mlx5: DR, Fix NULL vs IS_ERR checking in dr_domain_init_resources fcb32eb3d04d scsi: lpfc: Terminate string in lpfc_debugfs_nvmeio_trc_write() 4833ad4908a1 selinux: initialize proto variable in selinux_ip_postroute_compat() ec941a2277a1 recordmcount.pl: fix typo in s390 mcount regex a0e82d5ef992 memblock: fix memblock_phys_alloc() section mismatch error 7da855e93964 platform/x86: apple-gmux: use resource_size() with res d01e9ce1af61 parisc: Clear stale IIR value on instruction access rights trap 0643d9175dc6 tomoyo: use hwight16() in tomoyo_domain_quota_is_ok() e2048a1f9186 tomoyo: Check exceeded quota early in tomoyo_domain_quota_is_ok(). 210c7c6908f3 Input: i8042 - enable deferred probe quirk for ASUS UM325UA bb672eff7447 Input: i8042 - add deferred probe support Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit ada52c924b8033939a448d8cedfc4e587bfdbc46) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
index bad6f10905..9af2e622ac 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
@@ -6,7 +6,7 @@ KCONFIG_MODE = "--allnoconfig"
require recipes-kernel/linux/linux-yocto.inc
-LINUX_VERSION ?= "5.10.89"
+LINUX_VERSION ?= "5.10.90"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
@@ -15,9 +15,9 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine_qemuarm ?= "913d41ebe409dfd03c49fafd1923f8663df2a4ff"
-SRCREV_machine ?= "5575e67330fb6d979ed1cd2e9e64400b4c21b595"
-SRCREV_meta ?= "fdabd97ceceb2e3e74a132332c875f68b47b755b"
+SRCREV_machine_qemuarm ?= "c0774ebd6bc1c7541deb4f9a649a1a6bfa42853f"
+SRCREV_machine ?= "ab201bf6e3f9d187c7c26a0ec6537fadb41de918"
+SRCREV_meta ?= "65d66ac9789372923b42be0683a87955e52705a5"
PV = "${LINUX_VERSION}+git${SRCPV}"