aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.14.bb
diff options
context:
space:
mode:
authorStefan Stanacar <stefanx.stanacar@intel.com>2014-04-01 13:00:30 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-01 11:44:52 +0100
commit4b09a1869895e4cd18e82b7d190fbfea3c7922af (patch)
tree0b9459ba5ddfab597dbe8b956d339c0da090a38b /meta/recipes-kernel/linux/linux-yocto_3.14.bb
parent059dc5f4ef9bcf49cb6520f5f2ab1e739f4d42de (diff)
downloadopenembedded-core-contrib-4b09a1869895e4cd18e82b7d190fbfea3c7922af.tar.gz
qemux86-64: re-enable paravirt guest, bring it in sync with qemux86
Seems wrong that qemux86 has this enabled and qemux86-64 doesn't. Also this will allow people to use kvm with -cpu=host. Right now, runqemu qemux86-64 kvm uses -cpu=kvm64 because without this feature you can't use cpu=host on newer host kernels (>= 3.8). This basically reverts poky e6149ec6c4c14d3a939022cdc29ac94dced836dd / oe-core 64749308fadabb4aa7c39f360c6395827bc5eb3a The reason of that commit (which is more than a year old) was that on the AB running old kernels (2.6.37) we would see occasional shutdown failures. (but if memory serves me right the fix might have been just a coincidence). I've tested this change with by: - run tests on runqemu qemux86-64 (without kvm) (300 seconds) - run tests on runqemu qemux86-64 kvm (which uses by default cpu=kvm64) - (tests took 20 seconds) - run tests on runqemu qemux86-64 kvm with cpu=host - (tests took 18 seconds) [ YOCTO #5956 ] Signed-off-by: Stefan Stanacar <stefanx.stanacar@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.14.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.14.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.14.bb b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
index d5202cd439..46c42601fe 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
@@ -33,5 +33,5 @@ COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
-KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"