aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_4.1.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-07-07 14:39:05 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:24:47 +0100
commita04c634adc3d073701ecf2576fe9dd0cf8ace629 (patch)
tree64b214d66453b8efc08bf3c0b0497e1f08042a17 /meta/recipes-kernel/linux/linux-yocto_4.1.bb
parentd33f1ccd8ddf8eeaf262267d8618f2422adda629 (diff)
downloadopenembedded-core-contrib-a04c634adc3d073701ecf2576fe9dd0cf8ace629.tar.gz
linux-yocto/4.1/4.1: mei, usb and extcon changes
Backporting the following mainline changes to the 4.1 and 4.4 kernels: device property: Avoid potential dereferences of invalid pointers device property: convert to use match_string() helper lib/string: introduce match_string() helper device property: fix for a case of use-after-free device property: fwnode->secondary may contain ERR_PTR(-ENODEV) xhci: harden xhci_find_next_ext_cap against device removal xhci: rework xhci extended capability list parsing functions xhci: parse xhci protocol speed ID list for usb 3.1 usage extcon: Redefine the unique id of supported external connectors without 'enum extcon' type extcon: Remove optional print_name() function pointer of extcon_dev extcon: Update the prototype of extcon_register_notifier() with enum extcon extcon: Use capital letter for the name of external connectors extcon: Use the unique id for external connector instead of string extcon: Remove the optional name of extcon device extcon: adc-jack: Remove the unneeded num_cables field extcon: Alter MHL-TA cable name to TA cable name extcon: Unify the dock device names on max8997/77693 extcon: Unify the jig cable names on rt8973 and max14577/77693/77843 extcon: Fix the checkpatch warning and minor coding style issue extcon: Add extcon_get_edev_name() API to get the extcon device name extcon: Modify the device name as extcon[X] for sysfs extcon: Add manufactor name of each extcon device And the following config change: mei.cfg: Add CONFIG_INTEL_MEI_TXE=m Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_4.1.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index f673609b7f..49adad0fd1 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,15 +11,15 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "ce593534958d0bc6a3d1bc3036f425b9d7d9f5f6"
-SRCREV_machine_qemuarm64 ?= "6ea8af4a9bc8797d71e14d9e641d9e28b1dee917"
-SRCREV_machine_qemumips ?= "f1566b7d9fafd16b5dd98a313ffae1cab493a1c3"
-SRCREV_machine_qemuppc ?= "6ea8af4a9bc8797d71e14d9e641d9e28b1dee917"
-SRCREV_machine_qemux86 ?= "6ea8af4a9bc8797d71e14d9e641d9e28b1dee917"
-SRCREV_machine_qemux86-64 ?= "6ea8af4a9bc8797d71e14d9e641d9e28b1dee917"
-SRCREV_machine_qemumips64 ?= "8bac527ccf5cef97eac0dec7d94fb8cb668d7e13"
-SRCREV_machine ?= "6ea8af4a9bc8797d71e14d9e641d9e28b1dee917"
-SRCREV_meta ?= "886dacbd6290bbd5bb0632883f661fb57b232d94"
+SRCREV_machine_qemuarm ?= "494bf106c15685dafa318f418ce86228728006f1"
+SRCREV_machine_qemuarm64 ?= "75d56a13f86fc48002e4a3f9ed60546db30432b7"
+SRCREV_machine_qemumips ?= "3d9c0d5f502f7ae6f74766b2e9980df2cf5f661c"
+SRCREV_machine_qemuppc ?= "75d56a13f86fc48002e4a3f9ed60546db30432b7"
+SRCREV_machine_qemux86 ?= "75d56a13f86fc48002e4a3f9ed60546db30432b7"
+SRCREV_machine_qemux86-64 ?= "75d56a13f86fc48002e4a3f9ed60546db30432b7"
+SRCREV_machine_qemumips64 ?= "6c9b0acfa18a1c86da12ae17da643cde03dd82cd"
+SRCREV_machine ?= "75d56a13f86fc48002e4a3f9ed60546db30432b7"
+SRCREV_meta ?= "0845ec79bc2fbc45efcf4c44138fd698039960c5"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"