summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_5.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-08-14 17:26:11 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-15 13:33:07 +0100
commit569d3f5d0454ed31f2f6df29f1703246a3dcd715 (patch)
treee81443b5921d9f212e14a4e624daa8adf7ac9fae /meta/recipes-kernel/linux/linux-yocto_5.0.bb
parenta777e0f34e106455f963bd58fd8728a16c588c4d (diff)
downloadopenembedded-core-contrib-569d3f5d0454ed31f2f6df29f1703246a3dcd715.tar.gz
linux-yocto: add drm-bochs support
This allows better modesetting support for the '-vga std' emulated hardware provided by Qemu, which we want to standardize on. See here for background: https://bugzilla.yoctoproject.org/show_bug.cgi?id=13466 Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_5.0.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.0.bb b/meta/recipes-kernel/linux/linux-yocto_5.0.bb
index 898f824d48..887e88e087 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.0.bb
@@ -47,7 +47,7 @@ COMPATIBLE_MACHINE = "qemuarm|qemuarmv5|qemuarm64|qemux86|qemuppc|qemumips|qemum
# Functionality flags
KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
-KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
+KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc"
KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"