summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_5.0.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-03-06 11:37:11 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-06 16:42:37 +0000
commitc802c355f02e808b29d396fcc286da6f18ce6a78 (patch)
tree450b4d4d34335e2d9bac2d7f503adc874f45aaad /meta/recipes-kernel/linux/linux-yocto_5.0.bb
parentf6c825c41e3d4c14ae4ba0b2a07cc41d538e0d61 (diff)
downloadopenembedded-core-contrib-c802c355f02e808b29d396fcc286da6f18ce6a78.tar.gz
linux-yocto: introduce 5.0 versioned recipe
Introducing the 5.0 linux-yocto reference kernel, which will become the "latest" kernel as part of the spring yocto release. qemu* has been built and sanity tested against this kernel, and it is suitable to become the default build for the emulated references. Some minor configuration cleanup was performed, but otherwise, things are very similar to the 4.19 kernel config: 7fdb966db86 (HEAD -> yocto-5.0) aufs4: kbuild patch c76b027a8b2 iosched: remove configs for removed legacy io schedules 5d1f8102244 netfilter: drop removed config options 8ff16f508f5 kernel-yocto: 5.0 kernel prep Feature wise, this is a match for 4.19, with yaffs2 and aufs4 being kept around for another release. Aufs is scheduled for removal in the fall release. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_5.0.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.0.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.0.bb b/meta/recipes-kernel/linux/linux-yocto_5.0.bb
new file mode 100644
index 0000000000..768036e298
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_5.0.bb
@@ -0,0 +1,51 @@
+KBRANCH ?= "v5.0/standard/base"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+# board specific branches
+KBRANCH_qemuarm ?= "v5.0/standard/arm-versatile-926ejs"
+KBRANCH_qemuarm64 ?= "v5.0/standard/qemuarm64"
+KBRANCH_qemumips ?= "v5.0/standard/mti-malta32"
+KBRANCH_qemuppc ?= "v5.0/standard/qemuppc"
+KBRANCH_qemux86 ?= "v5.0/standard/base"
+KBRANCH_qemux86-64 ?= "v5.0/standard/base"
+KBRANCH_qemumips64 ?= "v5.0/standard/mti-malta64"
+
+SRCREV_machine_qemuarm ?= "1fbecad0e6a68b6c57b4f6ef8207e7e90ea764a3"
+SRCREV_machine_qemuarm64 ?= "1a0da7e50b77c82841efb501c648dbaca699eac2"
+SRCREV_machine_qemumips ?= "d9dd6d4cfe689efd5cb7bbacd118a3888ac7c517"
+SRCREV_machine_qemuppc ?= "1a0da7e50b77c82841efb501c648dbaca699eac2"
+SRCREV_machine_qemux86 ?= "1a0da7e50b77c82841efb501c648dbaca699eac2"
+SRCREV_machine_qemux86-64 ?= "1a0da7e50b77c82841efb501c648dbaca699eac2"
+SRCREV_machine_qemumips64 ?= "5f072445126e6a9e44f9435a552f4fcf6fc15499"
+SRCREV_machine ?= "1a0da7e50b77c82841efb501c648dbaca699eac2"
+SRCREV_meta ?= "8ae7073a934d80c4f4b808bc01884777454aae8f"
+
+# remap qemuarm to qemuarma15 for the 5.0 kernel
+# KMACHINE_qemuarm ?= "qemuarma15"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.0;destsuffix=${KMETA}"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+LINUX_VERSION ?= "5.0"
+
+DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
+DEPENDS += "openssl-native util-linux-native"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+KMETA = "kernel-meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
+
+KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"
+
+COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
+
+# Functionality flags
+KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
+KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
+KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
+KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"