summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_5.8.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-08-19 09:24:41 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-20 15:28:57 +0100
commitd3590f16d9c1b56813114113b74f7b6f01e6b0ba (patch)
treee56f218fc19bed5c6f963d36900c25419fb988fc /meta/recipes-kernel/linux/linux-yocto_5.8.bb
parent18edf84ec6cfcc137602f89ddc024d1fe1dcf03a (diff)
downloadopenembedded-core-contrib-d3590f16d9c1b56813114113b74f7b6f01e6b0ba.tar.gz
kernel-yocto/5.8: add gmp-native dependency
With the latest gcc10 plugins, the host tools need gmp support or we end up with: HOSTCXX -fPIC scripts/gcc-plugins/arm_ssp_per_task_plugin.o In file included from /home/pokybuild/yocto-worker/qemuarm/build/build/tmp/work/qemuarm-poky-linux-gnueabi/make-mod-scripts/1.0-r0/recipe-sysroot-native/usr/bin/arm-poky-linux-gnueabi/../../lib/arm-poky-linux-gnueabi/gcc/arm-poky-linux-gnueabi/10.1.0/plugin/include/gcc-plugin.h:28, from /home/pokybuild/yocto-worker/qemuarm/build/build/tmp/work-shared/qemuarm/kernel-source/scripts/gcc-plugins/gcc-common.h:7, from /home/pokybuild/yocto-worker/qemuarm/build/build/tmp/work-shared/qemuarm/kernel-source/scripts/gcc-plugins/arm_ssp_per_task_plugin.c:3: /home/pokybuild/yocto-worker/qemuarm/build/build/tmp/work/qemuarm-poky-linux-gnueabi/make-mod-scripts/1.0-r0/recipe-sysroot-native/usr/bin/arm-poky-linux-gnueabi/../../lib/arm-poky-linux-gnueabi/gcc/arm-poky-linux-gnueabi/10.1.0/plugin/include/system.h:687:10: fatal error: gmp.h: No such file or directory 687 | #include <gmp.h> | ^~~~~~~ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_5.8.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.8.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.8.bb b/meta/recipes-kernel/linux/linux-yocto_5.8.bb
index f9d23072fd..27345beca9 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.8.bb
@@ -34,6 +34,7 @@ LINUX_VERSION ?= "5.8"
DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
DEPENDS += "openssl-native util-linux-native"
+DEPENDS += "gmp-native"
PV = "${LINUX_VERSION}+git${SRCPV}"