aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/oprofile
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-28 11:53:35 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-29 15:15:47 +0100
commitef967c70182eeccb59c7511d838a7ecb0b2315c1 (patch)
treefd801c62907115b9e8377f835ff4eb688e0c6bb2 /meta/recipes-kernel/oprofile
parentb7ab82485e4514e07ab8a76e554da27ddc92e6c0 (diff)
downloadopenembedded-core-contrib-ef967c70182eeccb59c7511d838a7ecb0b2315c1.tar.gz
classes/meta: Add DISTRO_FEATURES check for gtk+/gtk3+
If you currently do a DISTRO_FEATURES_remove = "x11" with OE-Core, you see failures due to dependency problems. The work in resolving this was partially completed a while back. This adds in the markup mainly for gtk/gtk3+ recipes and means "bitbake world" will work successfully. Rather than code the gtk/gtk+ specific distro features into each recipe, a shared variable is used. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/oprofile')
-rw-r--r--meta/recipes-kernel/oprofile/oprofileui_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-kernel/oprofile/oprofileui_git.bb b/meta/recipes-kernel/oprofile/oprofileui_git.bb
index bb69d5404d..8fad099664 100644
--- a/meta/recipes-kernel/oprofile/oprofileui_git.bb
+++ b/meta/recipes-kernel/oprofile/oprofileui_git.bb
@@ -2,6 +2,9 @@ require oprofileui.inc
DEPENDS += "gtk+ libglade libxml2 avahi-ui gconf"
+inherit distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
+
SRCREV = "389e1875af4721d52c7e65cf9cfffb69b0ed6a59"
PV = "0.0+git${SRCPV}"