aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2012-06-24 23:26:33 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-04 14:54:11 +0100
commit487c3a72f0ac7121b79d2f78b81f1d4732bc258a (patch)
tree5f834078a2f02e47a2dae1b3db14d9a4491ae5ee /meta/recipes-kernel/perf
parentb647d2ab84ff0eb94f4b6a1b731d74aaf8c60b9d (diff)
downloadopenembedded-core-contrib-487c3a72f0ac7121b79d2f78b81f1d4732bc258a.tar.gz
perf: enable Python bindings
Add support to enable the perf python bindings. The combination of these changes and the changes in the python-config sections in the kernel Makefile enable all the python bindings currently available in perf. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta/recipes-kernel/perf')
-rw-r--r--meta/recipes-kernel/perf/perf_3.4.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf_3.4.bb b/meta/recipes-kernel/perf/perf_3.4.bb
index 997beb4aef..9f3648473f 100644
--- a/meta/recipes-kernel/perf/perf_3.4.bb
+++ b/meta/recipes-kernel/perf/perf_3.4.bb
@@ -9,7 +9,7 @@ as well."
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-PR = "r0"
+PR = "r1"
BUILDPERF_libc-uclibc = "no"
@@ -24,6 +24,13 @@ PROVIDES = "virtual/perf"
inherit kernel-arch
+# needed for building the tools/perf Python bindings
+inherit python-dir
+export STAGING_INCDIR
+export STAGING_LIBDIR
+export BUILD_SYS
+export HOST_SYS
+
S = "${STAGING_KERNEL_DIR}"
B = "${WORKDIR}/${BPN}-${PV}"
@@ -44,7 +51,10 @@ do_compile() {
do_install() {
oe_runmake DESTDIR=${D} install
+ oe_runmake DESTDIR=${D} install-python_ext
}
PACKAGE_ARCH = "${MACHINE_ARCH}"
+FILES_${PN}-dbg += "${libdir}/python*/site-packages/.debug"
+FILES_${PN} += "${libdir}/python*/site-packages"