aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-04-30 21:34:19 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-03 11:39:47 +0100
commit46f842039422aa35f62b03f11b648c02980ea1b1 (patch)
tree8086c33df2ef383eeafb5e9a081b5c7f75bf459b /meta/recipes-kernel/perf
parent388de1bfa1de1086d500aa8b2d4ece69cce6d5f6 (diff)
downloadopenembedded-core-contrib-46f842039422aa35f62b03f11b648c02980ea1b1.tar.gz
perf: fix build (and feature tests) for 4.1-rcX
The way that perf detects features has changed/moved via commit e6c76d620 [perf build: Move feature checks code under tools/build]. This code movement resulted in the definition of CC being dropped, and in turn the passing of --sysroot not part of the build. This results in feature tests failing with errors such as: In file included from test-pthread-attr-setaffinity-np.c:1:0: sysroots/x86_64-linux/usr/lib/x86_64-poky-linux/gcc/x86_64-poky-linux/4.9.2/include/stdint.h:9:26: fatal error: stdint.h: No such file or directory # include_next <stdint.h> ^ compilation terminated. While the fix is going upstream, we can modify the perf recipe to add the definition of CC into the Makefile, and we'll continue to work on patched and unpatched kernels. Upstream-status: Pending Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf')
-rw-r--r--meta/recipes-kernel/perf/perf.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 420fe6b57a..eb273740ee 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -150,6 +150,9 @@ do_configure_prepend () {
if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
fi
+ if [ -e "${S}/tools/build/Makefile.feature" ]; then
+ sed -i 's,CFLAGS=,CC="\$(CC)" CFLAGS=,' ${S}/tools/build/Makefile.feature
+ fi
# 3.17-rc1+ has a include issue for arm/powerpc. Temporarily sed in the appropriate include
if [ -e "${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c" ]; then