aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/systemtap
diff options
context:
space:
mode:
authorJavier Martinez Canillas <javier@dowhile0.org>2012-08-05 21:48:38 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:20:38 +0100
commit095f9c056373a252c0ba2679d8e6f4ad932a958d (patch)
tree24b1d96371424bf18e8c53a10a78191ef48ce793 /meta/recipes-kernel/systemtap
parentc0ebcac02023705aead0d2588224a62d64fe1752 (diff)
downloadopenembedded-core-contrib-095f9c056373a252c0ba2679d8e6f4ad932a958d.tar.gz
systemtap: use ${datadir} instead of /usr/share for packaging
It is considered good practice to use the build system provided variables instead of directly specify hardcoded paths. Signed-off-by: Javier Martinez Canillas <javier@dowhile0.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/systemtap')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap-uprobes_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap-uprobes_git.bb b/meta/recipes-kernel/systemtap/systemtap-uprobes_git.bb
index b328e6bac8..0cfcbe44ac 100644
--- a/meta/recipes-kernel/systemtap/systemtap-uprobes_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap-uprobes_git.bb
@@ -4,7 +4,7 @@ require systemtap_git.inc
DEPENDS = "systemtap virtual/kernel"
-PR = "r0"
+PR = "r1"
# On systems without CONFIG_UTRACE, this package is empty.
ALLOW_EMPTY_${PN} = "1"
@@ -36,7 +36,7 @@ do_compile() {
do_install() {
if [ -e "${S}/runtime/uprobes/uprobes.ko" ]
then
- install -d ${D}/usr/share/systemtap/runtime/uprobes/
- install -m 0644 ${S}/runtime/uprobes/uprobes.ko ${D}/usr/share/systemtap/runtime/uprobes/
+ install -d ${D}${datadir}/systemtap/runtime/uprobes/
+ install -m 0644 ${S}/runtime/uprobes/uprobes.ko ${D}${datadir}/systemtap/runtime/uprobes/
fi
}