aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/trace-cmd/trace-cmd_2.3.2.bb
diff options
context:
space:
mode:
authorYasir-Khan <yasir_khan@mentor.com>2014-08-08 20:41:08 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-11 10:53:08 +0100
commit3b769f03959ccb991391fe0451aa2cc4a4a95a70 (patch)
tree09ae28c9a3ff8d35a31b335ad46c5592f2be9f5c /meta/recipes-kernel/trace-cmd/trace-cmd_2.3.2.bb
parent4380b1ad385fd3e321408306b4f457e185a4119e (diff)
downloadopenembedded-core-contrib-3b769f03959ccb991391fe0451aa2cc4a4a95a70.tar.gz
trace-cmd: Update to version 2.3.2
Current trace-cmd version 1.2 throws "recorder error in splice input" error while recording a trace on kernel version 3.10. Update the trace-cmd version to latest 2.3.2 to resolve this error and drop the redundant patches. * patches dropped - not needed anymore - trace-cmd-Add-checks-for-invalid-pointers-to-fix-seg.patch - backport - trace-cmd-Do-not-call-stop_threads-if-doing-latency-.patch - backport - trace-cmd-Setting-plugin-to-nop-clears-data-before-i.patch - backport - trace-cmd-fix-syntax-error-of-shell.patch - backport (From OE-Core rev: 3b5e792f3245e28495d61d7d7e8df0ef30070ebc) Signed-off-by: Yasir-Khan <yasir_khan@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/trace-cmd/trace-cmd_2.3.2.bb')
-rw-r--r--meta/recipes-kernel/trace-cmd/trace-cmd_2.3.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-kernel/trace-cmd/trace-cmd_2.3.2.bb b/meta/recipes-kernel/trace-cmd/trace-cmd_2.3.2.bb
new file mode 100644
index 0000000000..8d26205672
--- /dev/null
+++ b/meta/recipes-kernel/trace-cmd/trace-cmd_2.3.2.bb
@@ -0,0 +1,36 @@
+SUMMARY = "User interface to Ftrace"
+LICENSE = "GPLv2 & LGPLv2.1"
+
+require trace-cmd.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+ file://trace-cmd.c;beginline=6;endline=8;md5=2c22c965a649ddd7973d7913c5634a5e \
+ file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \
+ file://trace-input.c;beginline=5;endine=8;md5=dafd8a1cade30b847a8686dd3628cea4 \
+"
+SRCREV = "79e08f8edb38c4c5098486caaa87ca90ba00f547"
+
+PV = "2.3.2+git${SRCPV}"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git;protocol=git;branch=trace-cmd-stable-v2.3 \
+"
+
+EXTRA_OEMAKE = "\
+ 'prefix=${prefix}' \
+ 'bindir=${bindir}' \
+ 'man_dir=${mandir}' \
+ 'html_install=${datadir}/kernelshark/html' \
+ 'img_install=${datadir}/kernelshark/html/images' \
+ \
+ 'bindir_relative=${@oe.path.relative(prefix, bindir)}' \
+ 'libdir=${@oe.path.relative(prefix, libdir)}' \
+ \
+ NO_PYTHON=1 \
+"
+
+FILES_${PN}-dbg += "${libdir}/trace-cmd/plugins/.debug"
+
+do_install() {
+ oe_runmake DESTDIR="${D}" install
+}
+