summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-11-23 16:28:33 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-26 16:58:55 +0000
commitc12a91827e88230b4ec702a88534d4c51c1aabe3 (patch)
treeabefb3978c9c7bda35cd7df23050ce92c03487c0 /meta/recipes-kernel
parenta8525391f8a519426c92f0e28895f426bfcb3f84 (diff)
downloadopenembedded-core-contrib-c12a91827e88230b4ec702a88534d4c51c1aabe3.tar.gz
linux-yocto-dev: introduce dt-validation PACKAGECONFIG
Add a PACKAGECONFIG to control which type of dt-validation is installed (full, or wrapped). This is currently in linux-yocto-dev, as 5.16 introduces the functionality of required dt schema validation. Other v5.16 providing recipes can use the base functionality as they desire (with or without PACKAGECONFIG). Over time, we can migrate the support the the core kernel classes .. in particular when more providers are at v5.16+ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-dev.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index ed94ab2517..6b6ea9a7e8 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -39,8 +39,16 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
DEPENDS += "openssl-native util-linux-native"
DEPENDS += "gmp-native libmpc-native"
-# yaml and dtschema are required for 5.16+ device tree validation
-DEPENDS += "libyaml-native python3-dtschema-native"
+
+# yaml and dtschema are required for 5.16+ device tree validation, libyaml is checked
+# via pkgconfig, so must always be present, but we can wrap the others to make them
+# conditional
+DEPENDS += "libyaml-native"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[dt-validation] = ",,python3-dtschema-native"
+# we need the wrappers if validation isn't in the packageconfig
+DEPENDS += "${@bb.utils.contains('PACKAGECONFIG', 'dt-validation', '', 'python3-dtschema-wrapper-native', d)}"
COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64|qemuriscv64)"