aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-09-09 09:22:22 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-29 12:11:48 +0100
commit32fcc621401e7761d9b96bc5b7bef143c1c29695 (patch)
treeae38ebf78e583759c9d0ee6a56cf087a41804dd1 /meta/recipes-kernel
parent1917bf7aa74aa1b86756c73c56537db2591115e5 (diff)
downloadopenembedded-core-contrib-32fcc621401e7761d9b96bc5b7bef143c1c29695.tar.gz
perf: fix issue about package splitting
Currently, perf can't split to perf-archive, perf-tests, perf-python and perf-perl. All files are included in perf package. Change the perfexecdir variable to make split successfull. Add python to RDEPENDS_perf-tests. Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 8112986a08..ea7571aa8e 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -129,7 +129,8 @@ do_configure_prepend () {
# config/Makefile.
if [ -e "${S}/tools/perf/config/Makefile" ]; then
# Match $(prefix)/$(lib) and $(prefix)/lib
- sed -i 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
+ sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
+ -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \
${S}/tools/perf/config/Makefile
fi
# We need to ensure the --sysroot option in CC is preserved
@@ -163,6 +164,7 @@ RDEPENDS_${PN} += "elfutils"
RDEPENDS_${PN}-archive =+ "bash"
RDEPENDS_${PN}-python =+ "bash python"
RDEPENDS_${PN}-perl =+ "bash perl perl-modules"
+RDEPENDS_${PN}-tests =+ "python"
RSUGGESTS_SCRIPTING = "${@perf_feature_enabled('perf-scripting', '${PN}-perl ${PN}-python', '',d)}"
RSUGGESTS_${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}"