summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/recipes-kernel
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadopenembedded-core-contrib-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/fuse/fuse-2.7.2/not-run-updaterc.d-on-host.patch15
-rw-r--r--meta/recipes-kernel/fuse/fuse.inc13
-rw-r--r--meta/recipes-kernel/fuse/fuse_2.7.2.bb22
3 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-kernel/fuse/fuse-2.7.2/not-run-updaterc.d-on-host.patch b/meta/recipes-kernel/fuse/fuse-2.7.2/not-run-updaterc.d-on-host.patch
new file mode 100644
index 0000000000..903a8baa9e
--- /dev/null
+++ b/meta/recipes-kernel/fuse/fuse-2.7.2/not-run-updaterc.d-on-host.patch
@@ -0,0 +1,15 @@
+Index: fuse-2.7.2/util/Makefile.am
+===================================================================
+--- fuse-2.7.2.orig/util/Makefile.am 2007-04-26 01:36:47.000000000 +0930
++++ fuse-2.7.2/util/Makefile.am 2008-02-10 16:43:19.000000000 +1030
+@@ -33,10 +33,6 @@
+ $(INSTALL_PROGRAM) $(srcdir)/mount.fuse $(DESTDIR)$(MOUNT_FUSE_PATH)/mount.fuse
+ $(mkdir_p) $(DESTDIR)$(INIT_D_PATH)
+ $(INSTALL_PROGRAM) $(srcdir)/init_script $(DESTDIR)$(INIT_D_PATH)/fuse
+- @if test -x /usr/sbin/update-rc.d; then \
+- echo "/usr/sbin/update-rc.d fuse start 34 S . start 41 0 6 . || true"; \
+- /usr/sbin/update-rc.d fuse start 34 S . start 41 0 6 . || true; \
+- fi
+
+ install-data-local:
+ $(mkdir_p) $(DESTDIR)$(UDEV_RULES_PATH)
diff --git a/meta/recipes-kernel/fuse/fuse.inc b/meta/recipes-kernel/fuse/fuse.inc
new file mode 100644
index 0000000000..c6755ac7c7
--- /dev/null
+++ b/meta/recipes-kernel/fuse/fuse.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
+HOMEPAGE = "http://fuse.sf.net"
+LICENSE = "GPL"
+DEPENDS = "virtual/fakeroot-native"
+RRECOMMENDS_fuse = "${@base_contains("MACHINE_FEATURES","kernel26","kernel-module-fuse","fuse-module",d)}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/fuse/fuse-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+fakeroot do_install() {
+ oe_runmake install DESTDIR=${D}
+}
diff --git a/meta/recipes-kernel/fuse/fuse_2.7.2.bb b/meta/recipes-kernel/fuse/fuse_2.7.2.bb
new file mode 100644
index 0000000000..d284a25f5f
--- /dev/null
+++ b/meta/recipes-kernel/fuse/fuse_2.7.2.bb
@@ -0,0 +1,22 @@
+require fuse.inc
+
+PR = "r0"
+
+SRC_URI += "file://not-run-updaterc.d-on-host.patch;patch=1"
+
+EXTRA_OECONF = " --disable-kernel-module"
+
+#package utils in a sperate package and stop debian.bbclass renaming it to libfuse-utils, we want it to be fuse-utils
+PACKAGES =+ "fuse-utils-dbg fuse-utils libulockmgr libulockmgr-dev libulockmgr-dbg"
+FILES_${PN} += "${libdir}/libfuse.so.*"
+FILES_${PN}-dev += "${libdir}/libfuse*.la"
+
+FILES_libulockmgr = "${libdir}/libulockmgr.so.*"
+FILES_libulockmgr-dev += "${libdir}/libulock*.la"
+FILES_libulockmgr-dbg += "${libdir}/.debug/libulock*"
+
+FILES_fuse-utils = "${bindir} ${base_sbindir}"
+FILES_fuse-utils-dbg = "${bindir}/.debug ${base_sbindir}/.debug"
+DEBIAN_NOAUTONAME_fuse-utils = "1"
+DEBIAN_NOAUTONAME_fuse-utils-dbg = "1"
+