aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad.inc
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2014-08-27 16:47:03 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-28 15:11:10 +0100
commit7bf062f2e2b92c2401fa2386b6281aae023b21a8 (patch)
treeb18ec36efe819201d0bc0ddcd8321790d87cdb97 /meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad.inc
parent413d5665cedd740125862e5eec5ca1f3b38b8363 (diff)
downloadopenembedded-core-contrib-7bf062f2e2b92c2401fa2386b6281aae023b21a8.tar.gz
gstreamer1.0-plugins-bad: Fix GL/GLES configuration
* Replace --disable/enable-gl with the individual EGL, GLES, GL switches (--disable-gl turns off GL support entirely) * Put the default opengl packageconfig into its own variable to make it easier for distros and BSP layers to define what to use (GL, GLES, or neither) * Add libglu as a dependency for desktop GL * Patch configure.ac to ensure libraries are only searched and linked to if the corresponding API isn't disabled (this prevents cases where libgstgl is linked to GLU even though desktop GL is dis- and GLES enabled) Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad.inc')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad.inc9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad.inc b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad.inc
index 8a7c5c1d62..52ef3b8486 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad.inc
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad.inc
@@ -8,19 +8,24 @@ S = "${WORKDIR}/gst-plugins-bad-${PV}"
inherit gettext
+# opengl packageconfig factored out to make it easy for distros
+# and BSP layers to pick either (desktop) opengl, gles2, or no GL
+PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
PACKAGECONFIG ??= " \
+ ${PACKAGECONFIG_GL} \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \
orc curl uvch264 neon sndfile \
hls sbc dash bz2 smoothstreaming \
"
+
# dash = Dynamic Adaptive Streaming over HTTP
PACKAGECONFIG[assrender] = "--enable-assrender,--disable-assrender,libass"
PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
-PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,virtual/egl virtual/libgles2"
+PACKAGECONFIG[gles2] = "--enable-gles2 --enable-egl,--disable-gles2 --disable-egl,virtual/libgles2 virtual/egl"
+PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,virtual/libgl libglu"
PACKAGECONFIG[faac] = "--enable-faac,--disable-faac,faac"
PACKAGECONFIG[faad] = "--enable-faad,--disable-faad,faad2"
PACKAGECONFIG[libmms] = "--enable-libmms,--disable-libmms,libmms"