aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/images
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-06-29 19:53:13 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-03 14:54:57 +0100
commitbd2d6016c067b9e406da78c45eaad463117ffb76 (patch)
tree03e6abae41691cb3091b57858cb24b66cb0bf1c7 /meta/recipes-sato/images
parentcf65e4ec8f3a47f4e4f199154adf165d31dfa567 (diff)
downloadopenembedded-core-contrib-bd2d6016c067b9e406da78c45eaad463117ffb76.tar.gz
core-image*sdk: Add kernel-dev to sdk images
While sdk images already have dev-pkgs included, the kernel-dev package is special and does not get installed. Add kernel-dev explicitly to the *sdk image recipes. Note: We have to be careful with "IMAGE_INSTALL +=" as it must appear after "inherit core-image" which makes an "IMAGE_INSTALL ?=" assignment. (From OE-Core rev: 337428316de3612a8e1efa70b3a4ba7cb6e058d2) Signed-off-by: Darren Hart <dvhart@linux.intel.com> CC: Jessica Zhang <jessica.zhang@intel.com> CC: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/images')
-rw-r--r--meta/recipes-sato/images/core-image-sato-sdk.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-sato/images/core-image-sato-sdk.bb b/meta/recipes-sato/images/core-image-sato-sdk.bb
index eed1698063..75ed64fd6b 100644
--- a/meta/recipes-sato/images/core-image-sato-sdk.bb
+++ b/meta/recipes-sato/images/core-image-sato-sdk.bb
@@ -11,3 +11,6 @@ EXTRA_IMAGE_FEATURES += "tools-debug tools-profile tools-testapps debug-tweaks"
LICENSE = "MIT"
inherit core-image
+
+IMAGE_INSTALL += "kernel-dev"
+