aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.10.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-02-29 13:48:14 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 18:05:22 +0100
commitff6dd0663419be8aae5f498eb15d9b09ed3f469a (patch)
tree932fcd52dc2ccacf4b2605fb162a9f275173e97f /meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.10.bb
parent7a69ef0c3a15a51206498a442267c7309ac737d1 (diff)
downloadopenembedded-core-contrib-ff6dd0663419be8aae5f498eb15d9b09ed3f469a.tar.gz
matchbox-panel-2: Upgrade to 2.10
* Changes in 2.10: - Port to GTK3, avoid all deprecated API - Add --mode for easier testing * Remove a backported patch. * License checksum changes because copyright years change (From OE-Core rev: 7a64be78d37af46f79342654c43adda945f12885) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.10.bb')
-rw-r--r--meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.10.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.10.bb b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.10.bb
new file mode 100644
index 0000000000..3ccd6a268b
--- /dev/null
+++ b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.10.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Simple GTK+ based panel for handheld devices"
+HOMEPAGE = "http://matchbox-project.org"
+BUGTRACKER = "http://bugzilla.yoctoproject.org/"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://matchbox-panel/mb-panel.h;endline=10;md5=0b7db28f4b6863fb853d0467e590019a \
+ file://applets/startup/startup.c;endline=22;md5=7cbcea60b667f609495222faf3e07917"
+
+DEPENDS = "gnome-common gtk+3 startup-notification dbus dbus-glib dbus-glib-native"
+DEPENDS += " ${@bb.utils.contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
+DEPENDS += " ${@bb.utils.contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
+
+# The startup-notification requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
+
+# SRCREV tagged 2.10
+SRCREV = "145a8075c66952dad9ab5f36d944c78c1ae3f4ab"
+
+RPROVIDES_${PN} = "matchbox-panel"
+RREPLACES_${PN} = "matchbox-panel"
+RCONFLICTS_${PN} = "matchbox-panel"
+
+SRC_URI = "git://git.yoctoproject.org/${BPN}"
+
+EXTRA_OECONF = "--enable-startup-notification --enable-dbus"
+EXTRA_OECONF += " ${@bb.utils.contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"
+EXTRA_OECONF += " ${@bb.utils.contains("MACHINE_FEATURES", "apm", "--with-battery=apm", "",d)}"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} += "${libdir}/matchbox-panel/*.so \
+ ${datadir}/matchbox-panel/brightness/*.png \
+ ${datadir}/matchbox-panel/startup/*.png \
+ ${datadir}/icons/"
+FILES_${PN}-dev += "${libdir}/matchbox-panel/*.la"
+
+inherit autotools pkgconfig distro_features_check