summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/icu
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2018-01-07 08:59:18 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-08 08:45:33 +0000
commite9dfe7eb7f61b909ae7d034e80cfbebc1fad018b (patch)
tree924e6999664c79d3647f345b931b0c242c015a22 /meta/recipes-support/icu
parent497b28d9ff0c094768462991709bfb19efa0fa56 (diff)
downloadopenembedded-core-contrib-e9dfe7eb7f61b909ae7d034e80cfbebc1fad018b.tar.gz
icu-dbg: improve reproducibility
Make sure build host references do not end up being compiled in the image. This only affects libicutu and icu-dbg. Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/icu')
-rw-r--r--meta/recipes-support/icu/icu.inc9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-support/icu/icu.inc b/meta/recipes-support/icu/icu.inc
index 3fb16b0f68..5cf7b11d59 100644
--- a/meta/recipes-support/icu/icu.inc
+++ b/meta/recipes-support/icu/icu.inc
@@ -38,6 +38,15 @@ do_configure_prepend_libc-musl () {
sed -i -e 's,DU_HAVE_STRTOD_L=1,DU_HAVE_STRTOD_L=0,' ${S}/configure.ac
}
+do_compile_prepend_class-target () {
+ # Make sure certain build host references do not end up being compiled
+ # in the image. This only affects libicutu and icu-dbg
+ sed \
+ -e 's,DU_BUILD=,DU_BUILD_unused=,g' \
+ -e '/^CPPFLAGS.*/ s,--sysroot=${STAGING_DIR_TARGET},,g' \
+ -i ${B}/tools/toolutil/Makefile
+}
+
PREPROCESS_RELOCATE_DIRS = "${datadir}/${BPN}/${PV}"
do_install_append_class-native() {
mkdir -p ${D}/${STAGING_ICU_DIR_NATIVE}/config