summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb
diff options
context:
space:
mode:
authorRandy MacLeod <Randy.MacLeod@windriver.com>2019-06-16 11:48:15 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-18 11:21:40 +0100
commit9592b318ccd6a8dca60d1060c8255ed8e62ef046 (patch)
treea495aeebab2f73ea813524d20e5daa93566e410a /meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb
parent587ba5f4bef18e8260fe671bd2e303140369a5e5 (diff)
downloadopenembedded-core-contrib-9592b318ccd6a8dca60d1060c8255ed8e62ef046.tar.gz
libcap-ng: split into libcap-ng/libcap-ng-python
util-linux's setpriv needs the libcap-ng library but not the python package so split the package up to enable this without a dependency loop. Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb')
-rw-r--r--meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb b/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb
new file mode 100644
index 0000000000..e49b445f57
--- /dev/null
+++ b/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb
@@ -0,0 +1,27 @@
+require libcap-ng.inc
+
+SUMMARY .= " - python"
+
+inherit lib_package autotools python3native
+
+DEPENDS += "libcap-ng python3 swig-native"
+
+S = "${WORKDIR}/libcap-ng-${PV}"
+
+EXTRA_OECONF += "--with-python --with-python3"
+EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}${PYTHON_ABI}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'"
+
+do_install_append() {
+ rm -rf ${D}${bindir}
+ rm -rf ${D}${libdir}/.debug
+ rm -f ${D}${libdir}/lib*
+ rm -rf ${D}${libdir}/pkgconfig
+ rm -rf ${D}${datadir}
+ rm -rf ${D}${includedir}
+}
+
+# PACKAGES = "${PN}"
+
+FILES_${PN} = "${libdir}/python${PYTHON_BASEVERSION}"
+FILES_${PN}-dbg =+ "${PYTHON_SITEPACKAGES_DIR}/.debug/_capng.so"
+