aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorMing Liu <ming.liu@windriver.com>2014-07-17 15:58:18 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-17 12:36:19 +0100
commit1bec8d6317588a2ee344a4830ceeab13dfd457a9 (patch)
treeb5ad8163144cb6f797d28dd55c5f0336d3611009 /meta/recipes-support
parent46ab196116f3f2555573ff65d2baf61a60ac120b (diff)
downloadopenembedded-core-contrib-1bec8d6317588a2ee344a4830ceeab13dfd457a9.tar.gz
gmp: use PACKAGECONFIG to address readline dependency
To avoid automatically detecting readline dependency, which will lead to a implicit build result. (From OE-Core rev: b98da859423a541e419bbf38edacf2320ce00c8d) Signed-off-by: Ming Liu <ming.liu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/gmp/gmp.inc3
-rw-r--r--meta/recipes-support/gmp/gmp_4.2.1.bb3
2 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-support/gmp/gmp.inc b/meta/recipes-support/gmp/gmp.inc
index d025e07256..6aedc85f58 100644
--- a/meta/recipes-support/gmp/gmp.inc
+++ b/meta/recipes-support/gmp/gmp.inc
@@ -18,6 +18,9 @@ acpaths = ""
BBCLASSEXTEND = "native nativesdk"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[readline] = "--with-readline=yes,--with-readline=no,readline"
+
EXTRA_OECONF += " --enable-cxx=detect"
PACKAGES =+ "libgmpxx"
diff --git a/meta/recipes-support/gmp/gmp_4.2.1.bb b/meta/recipes-support/gmp/gmp_4.2.1.bb
index 5c93925daa..69ad0ca670 100644
--- a/meta/recipes-support/gmp/gmp_4.2.1.bb
+++ b/meta/recipes-support/gmp/gmp_4.2.1.bb
@@ -17,4 +17,7 @@ SRC_URI = "${GNU_MIRROR}/gmp/${BP}.tar.bz2 \
SRC_URI[md5sum] = "091c56e0e1cca6b09b17b69d47ef18e3"
SRC_URI[sha256sum] = "d07ffcb37eecec35c5ec72516d10b35fdf6e6fef1fcf1dcd37e30b8cbf8bf941"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[readline] = "--with-readline=yes,--with-readline=no,readline"
+
inherit autotools texinfo