aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMike Looijmans <mike.looijmans@topic.nl>2014-08-12 09:54:58 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-15 18:19:54 +0100
commit6c95440ed5c181754bb7c04da678081498840683 (patch)
tree2eae57bd929fc25dd573b220514260307675ccb3 /meta
parent3c7301adce142bab64d49b5be7c39d8b223591f5 (diff)
downloadopenembedded-core-contrib-6c95440ed5c181754bb7c04da678081498840683.tar.gz
squashfs-tools: Add support for LZO and LZ4 compression
For systems that want to optimize for speed rather than size, LZO is usually a better choice than gzip or XZ. Kernel support for LZO has been available since 2.6.29. LZ4 support isn't in the mainline kernel yet, but we might as well add it now for those who want to experiment with it. Signed-off-by: Mike Looijmans <mike.looijmans@topic.nl> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
index 54fd3bb85f..e3783fd81d 100644
--- a/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
+++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
@@ -6,7 +6,7 @@ LICENSE = "GPL-2 & PD"
LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://../../7zC.txt;beginline=12;endline=16;md5=2056cd6d919ebc3807602143c7449a7c \
"
-DEPENDS = "attr zlib xz"
+DEPENDS = "attr zlib xz lzo lz4"
SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${PV}.tar.gz;name=squashfs \
http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2;name=lzma \
@@ -23,7 +23,7 @@ S = "${WORKDIR}/squashfs${PV}/squashfs-tools"
# EXTRA_OEMAKE is typically: -e MAKEFLAGS=
# the -e causes problems as CFLAGS is modified in the Makefile, so
# we redefine EXTRA_OEMAKE here
-EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1"
+EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1 LZO_SUPPORT=1 LZ4_SUPPORT=1"
do_compile() {
oe_runmake mksquashfs