aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2016-09-02 22:39:37 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-05 11:55:51 +0100
commit3982b57e179872eb119ecb75237981beec398cb6 (patch)
treedc6c2ff6e3945b2c9010da24b52bb1dc20397c2a /meta
parent8ded5da8952e4a39851e0184bde323e01dd73d2c (diff)
downloadopenembedded-core-contrib-3982b57e179872eb119ecb75237981beec398cb6.tar.gz
e2fsprogs: packaging cleanups (compile_et & mk_cmds)
While comparing what were supposed to be similar filesystems from different build machines, some issues have been noticed in the e2fsprogs recipe, in particular with the compile_et and mk_cmds utilities. 1) target: move compile_et and mk_cmds into the -dev package Both are development tools, from the man pages: compile_et - error table compiler compile_et converts a table listing error-code names and associated messages into a C source file suitable for use with the com_err(3) library. mk_cmds - error table compiler mk_cmds converts a table listing command names and associated help messages into a C source file suitable for use with the ss(3) library. 2) native/nativesdk Also apply cleaning of host path (build directory) here, so that only the sysroot directory remains, which is properly adjusted by the sstate handling. 3) make cleaning of host path actually work The existing sed command wasn't working, in particular for compile_et; we fix up the sed command so that removal of references to the local build directory really works. Do the same changes for mk_cmds, for consistency. Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs_1.43.bb12
1 files changed, 5 insertions, 7 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.43.bb b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.43.bb
index 837224cc72..f4855bc430 100644
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.43.bb
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.43.bb
@@ -52,6 +52,10 @@ do_install () {
mv ${D}${bindir}/chattr ${D}${base_bindir}/chattr.e2fsprogs
install -v -m 755 ${S}/contrib/populate-extfs.sh ${D}${base_sbindir}/
+
+ # Clean host path (build directory) in compile_et, mk_cmds
+ sed -i -e "s,\(ET_DIR=.*\)${S}/lib/et\(.*\),\1${datadir}/et\2,g" ${D}${bindir}/compile_et
+ sed -i -e "s,\(SS_DIR=.*\)${S}/lib/ss\(.*\),\1${datadir}/ss\2,g" ${D}${bindir}/mk_cmds
}
# Need to find the right mke2fs.conf file
@@ -61,12 +65,6 @@ e2fsprogs_conf_fixup () {
done
}
-do_install_append_class-target() {
- # Clean host path in compile_et, mk_cmds
- sed -i -e "s,ET_DIR=\"${S}/lib/et\",ET_DIR=\"${datadir}/et\",g" ${D}${bindir}/compile_et
- sed -i -e "s,SS_DIR=\"${S}/lib/ss\",SS_DIR=\"${datadir}/ss\",g" ${D}${bindir}/mk_cmds
-}
-
do_install_append_class-native() {
e2fsprogs_conf_fixup
}
@@ -90,7 +88,7 @@ FILES_libcomerr = "${base_libdir}/libcom_err.so.*"
FILES_libss = "${base_libdir}/libss.so.*"
FILES_libe2p = "${base_libdir}/libe2p.so.*"
FILES_libext2fs = "${libdir}/e2initrd_helper ${base_libdir}/libext2fs.so.*"
-FILES_${PN}-dev += "${datadir}/*/*.awk ${datadir}/*/*.sed ${base_libdir}/*.so"
+FILES_${PN}-dev += "${datadir}/*/*.awk ${datadir}/*/*.sed ${base_libdir}/*.so ${bindir}/compile_et ${bindir}/mk_cmds"
ALTERNATIVE_${PN} = "chattr"
ALTERNATIVE_PRIORITY = "100"