aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorDaniel McGregor <daniel.mcgregor@vecima.com>2016-06-15 09:03:36 -0600
committerDaniel McGregor <daniel.mcgregor@vecima.com>2016-07-08 12:34:49 -0600
commit10756e9db44816622239ab48a0fdf91642f688a9 (patch)
tree59fb1bb66f33de117441f927ce90358c2cab363d /meta
parented4957c444a2982c19e2f1f96d9afb2a992c1daf (diff)
downloadopenembedded-core-contrib-10756e9db44816622239ab48a0fdf91642f688a9.tar.gz
patchelf: update recipe version to version 0.9
This fixes uninative go builds. Without this, native recipes written in go fail to update the runtime linker. Signed-off-by: Dan McGregor <daniel.mcgregor@vecima.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/patchelf/patchelf/maxsize.patch10
-rw-r--r--meta/recipes-devtools/patchelf/patchelf/skip-empty.patch26
-rw-r--r--meta/recipes-devtools/patchelf/patchelf_0.9.bb (renamed from meta/recipes-devtools/patchelf/patchelf_0.8.bb)5
3 files changed, 34 insertions, 7 deletions
diff --git a/meta/recipes-devtools/patchelf/patchelf/maxsize.patch b/meta/recipes-devtools/patchelf/patchelf/maxsize.patch
index cc04a89e69..afc6d30bb0 100644
--- a/meta/recipes-devtools/patchelf/patchelf/maxsize.patch
+++ b/meta/recipes-devtools/patchelf/patchelf/maxsize.patch
@@ -16,15 +16,15 @@ RP
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/patchelf.cc b/src/patchelf.cc
-index 8566ed9..df75593 100644
+index fe51f77..f7cb648 100644
--- a/src/patchelf.cc
+++ b/src/patchelf.cc
-@@ -248,7 +248,7 @@ static void readFile(string fileName, mode_t * fileMode)
+@@ -256,7 +256,7 @@ static void readFile(string fileName)
+ struct stat st;
if (stat(fileName.c_str(), &st) != 0) error("stat");
fileSize = st.st_size;
- *fileMode = st.st_mode;
-- maxSize = fileSize + 8 * 1024 * 1024;
+- maxSize = fileSize + 32 * 1024 * 1024;
+ maxSize = fileSize + 64 * 1024 * 1024;
contents = (unsigned char *) malloc(fileSize + maxSize);
- if (!contents) abort(); \ No newline at end of file
+ if (!contents) abort();
diff --git a/meta/recipes-devtools/patchelf/patchelf/skip-empty.patch b/meta/recipes-devtools/patchelf/patchelf/skip-empty.patch
new file mode 100644
index 0000000000..f0caa46d92
--- /dev/null
+++ b/meta/recipes-devtools/patchelf/patchelf/skip-empty.patch
@@ -0,0 +1,26 @@
+From 40a9673d6816f0af68fe194460193b59bfc3ebcc Mon Sep 17 00:00:00 2001
+From: Piotr Gaczkowski <DoomHammerNG@gmail.com>
+Date: Tue, 3 May 2016 10:01:21 +0200
+Subject: [PATCH] Skip empty section (fixes #66)
+
+---
+ src/patchelf.cc | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/patchelf.cc b/src/patchelf.cc
+index 136098f..fe51f77 100644
+--- a/src/patchelf.cc
++++ b/src/patchelf.cc
+@@ -684,6 +684,9 @@ void ElfFile<ElfFileParamNames>::rewriteSectionsExecutable()
+ for (unsigned int i = 1; i <= lastReplaced; ++i) {
+ Elf_Shdr & shdr(shdrs[i]);
+ string sectionName = getSectionName(shdr);
++ if (sectionName == "") {
++ continue;
++ }
+ debug("looking at section `%s'\n", sectionName.c_str());
+ /* !!! Why do we stop after a .dynstr section? I can't
+ remember! */
+--
+2.8.2
+
diff --git a/meta/recipes-devtools/patchelf/patchelf_0.8.bb b/meta/recipes-devtools/patchelf/patchelf_0.9.bb
index 8484a7e589..6f45796c88 100644
--- a/meta/recipes-devtools/patchelf/patchelf_0.8.bb
+++ b/meta/recipes-devtools/patchelf/patchelf_0.9.bb
@@ -1,10 +1,11 @@
SRC_URI = "http://nixos.org/releases/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.bz2 \
+ file://skip-empty.patch \
file://maxsize.patch"
LICENSE = "GPLv3"
SUMMARY = "Tool to allow editing of RPATH and interpreter fields in ELF binaries"
-SRC_URI[md5sum] = "5b151e3c83b31f5931b4a9fc01635bfd"
-SRC_URI[sha256sum] = "c99f84d124347340c36707089ec8f70530abd56e7827c54d506eb4cc097a17e7"
+SRC_URI[md5sum] = "d02687629c7e1698a486a93a0d607947"
+SRC_URI[sha256sum] = "a0f65c1ba148890e9f2f7823f4bedf7ecad5417772f64f994004f59a39014f83"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"