aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2013-03-18 18:55:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-19 11:54:22 +0000
commit05985a7c22655a2f35ff0fcec723173c404c7993 (patch)
tree39b61d3699cf606b621ad4fb4749ed96e2225eca /meta
parent683abbce582a9366aca859bc7b69c56ba0565b1d (diff)
downloadopenembedded-core-contrib-05985a7c22655a2f35ff0fcec723173c404c7993.tar.gz
layer.conf: avoid unnecessary early expansion with :=
bitbake handles immediate expansions of LAYERDIR for us automatically. (From OE-Core rev: 643ac87145eba5dc105377041bc3deb163b62926) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/conf/layer.conf6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/conf/layer.conf b/meta/conf/layer.conf
index 6e5cd0cf8d..81f1071a91 100644
--- a/meta/conf/layer.conf
+++ b/meta/conf/layer.conf
@@ -4,7 +4,7 @@ BBPATH .= ":${LAYERDIR}"
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb"
BBFILE_COLLECTIONS += "core"
-BBFILE_PATTERN_core := "^${LAYERDIR}/"
+BBFILE_PATTERN_core = "^${LAYERDIR}/"
BBFILE_PRIORITY_core = "5"
# This should only be incremented on significant changes that will
@@ -12,10 +12,10 @@ BBFILE_PRIORITY_core = "5"
LAYERVERSION_core = "1"
# Set a variable to get to the top of the metadata location
-COREBASE := '${@os.path.normpath("${LAYERDIR}/../")}'
+COREBASE = '${@os.path.normpath("${LAYERDIR}/../")}'
# Set path to qemu image tests included in this layer
-QEMUIMAGETESTS := "${COREBASE}/scripts/qemuimage-tests"
+QEMUIMAGETESTS = "${COREBASE}/scripts/qemuimage-tests"
SIGGEN_EXCLUDERECIPES_ABISAFE += " \
sysvinit-inittab \