summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-04 11:29:31 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-06 12:44:25 +0100
commita34420e1bdb9a695fe7abd3b26426d7ae6113349 (patch)
treec906e39459ac19ce03e4f489a64664b980dd24dc /meta
parent6c4d581c35ebd51c4b080ac38175d93f0480f97d (diff)
downloadopenembedded-core-contrib-a34420e1bdb9a695fe7abd3b26426d7ae6113349.tar.gz
binutils/glibc-testsuite: inherit nopackages to fix world builds
These recipes don't need to generate packages but did contain the packaging tasks which would be triggered by a world build. They showed warnings or errors. Simplest fix is to remove the unneeded tasks with the nopackages class. Also don't attempt stash_locales task Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/glibc/glibc-testsuite_2.30.bb2
-rw-r--r--meta/recipes-devtools/binutils/binutils-cross-testsuite_2.32.bb2
2 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc-testsuite_2.30.bb b/meta/recipes-core/glibc/glibc-testsuite_2.30.bb
index 88764d9e2b..64fa8d87df 100644
--- a/meta/recipes-core/glibc/glibc-testsuite_2.30.bb
+++ b/meta/recipes-core/glibc/glibc-testsuite_2.30.bb
@@ -49,3 +49,5 @@ do_check () {
}
addtask do_check after do_compile
+inherit nopackages
+deltask do_stash_locale
diff --git a/meta/recipes-devtools/binutils/binutils-cross-testsuite_2.32.bb b/meta/recipes-devtools/binutils/binutils-cross-testsuite_2.32.bb
index e62e64e8ae..07a8e7c417 100644
--- a/meta/recipes-devtools/binutils/binutils-cross-testsuite_2.32.bb
+++ b/meta/recipes-devtools/binutils/binutils-cross-testsuite_2.32.bb
@@ -9,6 +9,8 @@ DEPENDS += "binutils-native"
deltask do_compile
deltask do_install
+inherit nopackages
+
do_configure[dirs] += "${B}/ld ${B}/bfd"
do_configure() {
# create config.h, oe enables initfini-array by default