aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-02-09 16:07:46 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-10 13:36:57 +0000
commit6064f6bd7c28640db59a216aa578f3cca6219b1f (patch)
tree915268dee0d10040a5a9f8860f9b97689333f737 /meta
parent50ad5230ea9e0982cdfda23fb9fcfccf89d28f29 (diff)
downloadopenembedded-core-contrib-6064f6bd7c28640db59a216aa578f3cca6219b1f.tar.gz
sat-solver: Fix build with zlib 1.2.6
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/sat-solver/sat-solver/0001-sat_xfopen.c-Forward-port-to-zlib-1.2.6-gzFile.patch57
-rw-r--r--meta/recipes-extended/sat-solver/sat-solver_git.bb3
2 files changed, 59 insertions, 1 deletions
diff --git a/meta/recipes-extended/sat-solver/sat-solver/0001-sat_xfopen.c-Forward-port-to-zlib-1.2.6-gzFile.patch b/meta/recipes-extended/sat-solver/sat-solver/0001-sat_xfopen.c-Forward-port-to-zlib-1.2.6-gzFile.patch
new file mode 100644
index 0000000000..402d16ec56
--- /dev/null
+++ b/meta/recipes-extended/sat-solver/sat-solver/0001-sat_xfopen.c-Forward-port-to-zlib-1.2.6-gzFile.patch
@@ -0,0 +1,57 @@
+From bbbb4fb9b7c85fde90608710dff09480696c6567 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 9 Feb 2012 16:01:56 -0800
+Subject: [PATCH] sat_xfopen.c: Forward port to zlib 1.2.6 gzFile
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+---
+ ext/sat_xfopen.c | 10 +++++-----
+ 1 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/ext/sat_xfopen.c b/ext/sat_xfopen.c
+index cf943cf..b3d458d 100644
+--- a/ext/sat_xfopen.c
++++ b/ext/sat_xfopen.c
+@@ -16,16 +16,16 @@
+
+ static ssize_t cookie_gzread(void *cookie, char *buf, size_t nbytes)
+ {
+- return gzread((gzFile *)cookie, buf, nbytes);
++ return gzread((gzFile)cookie, buf, nbytes);
+ }
+
+ static int
+ cookie_gzclose(void *cookie)
+ {
+- return gzclose((gzFile *)cookie);
++ return gzclose((gzFile)cookie);
+ }
+
+-static FILE *mygzfopen(gzFile* gzf)
++static FILE *mygzfopen(gzFile gzf)
+ {
+ #ifdef HAVE_FUNOPEN
+ return funopen(
+@@ -49,7 +49,7 @@ FILE *
+ sat_xfopen(const char *fn, const char *mode)
+ {
+ char *suf;
+- gzFile *gzf;
++ gzFile gzf;
+
+ if (!fn)
+ return 0;
+@@ -68,7 +68,7 @@ FILE *
+ sat_xfopen_fd(const char *fn, int fd, const char *mode)
+ {
+ char *suf;
+- gzFile *gzf;
++ gzFile gzf;
+
+ suf = fn ? strrchr(fn, '.') : 0;
+ if (!mode)
+--
+1.7.5.4
+
diff --git a/meta/recipes-extended/sat-solver/sat-solver_git.bb b/meta/recipes-extended/sat-solver/sat-solver_git.bb
index e243c6add8..9d8422fef4 100644
--- a/meta/recipes-extended/sat-solver/sat-solver_git.bb
+++ b/meta/recipes-extended/sat-solver/sat-solver_git.bb
@@ -8,7 +8,7 @@ DEPENDS = "libcheck rpm zlib expat db"
SRCREV = "0a7378d5f482f477a01cf1690d76871ab8bdcc32"
PV = "0.0-git${SRCPV}"
-PR = "r12"
+PR = "r13"
PARALLEL_MAKE=""
@@ -19,6 +19,7 @@ SRC_URI = "git://github.com/openSUSE/sat-solver.git;protocol=git \
file://db5.patch \
file://sat-solver_core.patch \
file://fix_gcc-4.6.0_compile_issue.patch \
+ file://0001-sat_xfopen.c-Forward-port-to-zlib-1.2.6-gzFile.patch \
"
S = "${WORKDIR}/git"