summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-08 15:59:53 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-10 10:29:44 +0000
commit6ff409d0d70b2ee0580d948c9fe50a1c9f224ac6 (patch)
tree4acfe1a87ee848ba0a6f2548faee4b2ee66c9776 /meta
parent5fc7d4a4c428d5be7103d8e9345d23038dae4247 (diff)
downloadopenembedded-core-contrib-6ff409d0d70b2ee0580d948c9fe50a1c9f224ac6.tar.gz
webkitgtk: Use linker options to reduce memory overhead during linking
Helps builds on machines with less RAM ( 8G ) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk/reduce-memory-overheads.patch22
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.30.5.bb1
2 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk/reduce-memory-overheads.patch b/meta/recipes-sato/webkit/webkitgtk/reduce-memory-overheads.patch
new file mode 100644
index 0000000000..0493150a91
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk/reduce-memory-overheads.patch
@@ -0,0 +1,22 @@
+From: Alberto Garcia <berto@igalia.com>
+Subject: Reduce memory usage when not using the Gold linker
+Bug-Debian: https://bugs.debian.org/949621
+Forwarded: no
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/Source/cmake/OptionsCommon.cmake
++++ b/Source/cmake/OptionsCommon.cmake
+@@ -95,6 +95,12 @@ option(GCC_OFFLINEASM_SOURCE_MAP
+ "Produce debug line information for offlineasm-generated code"
+ ${GCC_OFFLINEASM_SOURCE_MAP_DEFAULT})
+
++# Pass --reduce-memory-overheads to the bfd linker in order to save memory
++if (NOT USE_LD_GOLD)
++ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--reduce-memory-overheads")
++ set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--reduce-memory-overheads")
++endif ()
++
+ # Enable the usage of OpenMP.
+ # - At this moment, OpenMP is only used as an alternative implementation
+ # to native threads for the parallelization of the SVG filters.
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.30.5.bb b/meta/recipes-sato/webkit/webkitgtk_2.30.5.bb
index 2928b8e55b..a1dd76ce81 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.30.5.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.30.5.bb
@@ -18,6 +18,7 @@ SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
file://0001-Fix-build-with-musl.patch \
file://include_array.patch \
file://include_xutil.patch \
+ file://reduce-memory-overheads.patch \
"
SRC_URI[sha256sum] = "7d0dab08e3c5ae07bec80b2822ef42e952765d5724cac86eb23999bfed5a7f1f"