summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-07-14 10:07:17 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:24:53 +0100
commit71794837b477a78e2f5408348e269f58f9b1ec7e (patch)
tree3e5eb9f5d537e6cc5079fe73b19400102c3e7590 /meta
parent8dd7655211adff5731f0e8f187fad35d9e09862a (diff)
downloadopenembedded-core-contrib-71794837b477a78e2f5408348e269f58f9b1ec7e.tar.gz
bash: ensure LDFLAGS is passed when building ptest
Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/bash/bash-3.2.48/build-tests.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-extended/bash/bash-3.2.48/build-tests.patch b/meta/recipes-extended/bash/bash-3.2.48/build-tests.patch
index 91341ee696..e63457cf2b 100644
--- a/meta/recipes-extended/bash/bash-3.2.48/build-tests.patch
+++ b/meta/recipes-extended/bash/bash-3.2.48/build-tests.patch
@@ -11,15 +11,15 @@ diff -dNaur bash-3.2.48/Makefile.in.orig bash-3.2.48/Makefile.in
recho$(EXEEXT): $(SUPPORT_SRC)recho.c
- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)recho.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
++ @$(CC) $(CCFLAGS) $(LDFLAGS) -o $@ $<
zecho$(EXEEXT): $(SUPPORT_SRC)zecho.c
- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)zecho.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
++ @$(CC) $(CCFLAGS) $(LDFLAGS) -o $@ $<
printenv$(EXEEXT): $(SUPPORT_SRC)printenv.c
- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)printenv.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
++ @$(CC) $(CCFLAGS) $(LDFLAGS) -o $@ $<
-test tests check: force $(Program) $(TESTS_SUPPORT)
+test tests check: