aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/contrib/test_build_time_worker.sh
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-19 15:14:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-20 15:27:31 +0100
commit1dd5095ff703b7813cb7cb12091078e28e0f9ee0 (patch)
tree9f3ae76a4259053f774f351d429a8bc4caee2d03 /scripts/contrib/test_build_time_worker.sh
parent114960a7c4c1be6d294b2cf9915a9396045859d1 (diff)
downloadopenembedded-core-contrib-1dd5095ff703b7813cb7cb12091078e28e0f9ee0.tar.gz
scripts/contrib: add build time regression test script
test_build_time.sh is a bash script intended to be used in conjunction with "git bisect run" in order to find regressions in build time, however it can also be used independently. It cleans out the build output directories, runs a specified worker script (an example is test_build_time_worker.sh) under TIME(1), logs the results, and returns a value telling "git bisect run" whether the build time is good (under the specified threshold) or bad (over it). (From OE-Core rev: d866a36d7839247e8cf61512a0092d7f4f396d1a) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/contrib/test_build_time_worker.sh')
-rwxr-xr-xscripts/contrib/test_build_time_worker.sh37
1 files changed, 37 insertions, 0 deletions
diff --git a/scripts/contrib/test_build_time_worker.sh b/scripts/contrib/test_build_time_worker.sh
new file mode 100755
index 0000000000..8e20a9ea7d
--- /dev/null
+++ b/scripts/contrib/test_build_time_worker.sh
@@ -0,0 +1,37 @@
+#!/bin/bash
+
+# This is an example script to be used in conjunction with test_build_time.sh
+
+if [ "$TEST_BUILDDIR" = "" ] ; then
+ echo "TEST_BUILDDIR is not set"
+ exit 1
+fi
+
+buildsubdir=`basename $TEST_BUILDDIR`
+if [ ! -d $buildsubdir ] ; then
+ echo "Unable to find build subdir $buildsubdir in current directory"
+ exit 1
+fi
+
+if [ -f oe-init-build-env ] ; then
+ . ./oe-init-build-env $buildsubdir
+elif [ -f poky-init-build-env ] ; then
+ . ./poky-init-build-env $buildsubdir
+else
+ echo "Unable to find build environment setup script"
+ exit 1
+fi
+
+if [ -f ../meta/recipes-sato/images/core-image-sato.bb ] ; then
+ target="core-image-sato"
+else
+ target="poky-image-sato"
+fi
+
+echo "Build started at `date "+%Y-%m-%d %H:%M:%S"`"
+echo "bitbake $target"
+bitbake $target
+ret=$?
+echo "Build finished at `date "+%Y-%m-%d %H:%M:%S"`"
+exit $ret
+