summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-connectivity/libuv/libuv_1.34.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/libuv/libuv_1.34.0.bb b/meta/recipes-connectivity/libuv/libuv_1.34.0.bb
new file mode 100644
index 0000000000..b842bbda7a
--- /dev/null
+++ b/meta/recipes-connectivity/libuv/libuv_1.34.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "A multi-platform support library with a focus on asynchronous I/O"
+HOMEPAGE = "https://github.com/libuv/libuv"
+BUGTRACKER = "https://github.com/libuv/libuv/issues"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a68902a430e32200263d182d44924d47"
+
+SRCREV = "15ae750151ac9341e5945eb38f8982d59fb99201"
+SRC_URI = "git://github.com/libuv/libuv;branch=v1.x"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+do_configure() {
+ ${S}/autogen.sh || bbnote "${PN} failed to autogen.sh"
+ oe_runconf
+}
+
+BBCLASSEXTEND = "native"