aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/classes/kernel-yocto.bbclass7
-rw-r--r--meta/recipes-kernel/kern-tools/kern-tools-native_git.bb2
2 files changed, 8 insertions, 1 deletions
diff --git a/meta/classes/kernel-yocto.bbclass b/meta/classes/kernel-yocto.bbclass
index 818a07e219..536434fdf1 100644
--- a/meta/classes/kernel-yocto.bbclass
+++ b/meta/classes/kernel-yocto.bbclass
@@ -136,6 +136,13 @@ do_validate_branches() {
return
fi
+ # nothing to do if SRCREV=${AUTOREV}
+ if [ "${SRCREV_machine}" = "AUTOINC" ]; then
+ # restore the branch for builds
+ git checkout -f ${KBRANCH}
+ return
+ fi
+
branch_head=`git show-ref -s --heads ${KBRANCH}`
meta_head=`git show-ref -s --heads ${KMETA}`
target_branch_head="${SRCREV_machine}"
diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index 829d105d2c..f7600ca5b6 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=e2bf4415f3d8
DEPENDS = "git-native guilt-native"
-SRCREV = "ecbdf3cdf6705a63dcb3c50bb24c311046f0b35c"
+SRCREV = "f8eb067b023d590b6cd8deddf6f96d6a820997af"
PR = r10
PV = "0.1+git${SRCPV}"