summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbitbake/bin/bitbake1
-rw-r--r--openembedded/conf/bitbake.conf2
-rw-r--r--openembedded/packages/quilt/quilt-native_0.42.bb3
3 files changed, 5 insertions, 1 deletions
diff --git a/bitbake/bin/bitbake b/bitbake/bin/bitbake
index b1fd76a4f1..f371bfe165 100755
--- a/bitbake/bin/bitbake
+++ b/bitbake/bin/bitbake
@@ -655,6 +655,7 @@ class BBCooker:
if (item == pn):
rdepends += bb.utils.explode_deps(bb.data.getVar('RDEPENDS', the_data, True) or "")
rdepends += bb.utils.explode_deps(bb.data.getVar('RRECOMMENDS', the_data, True) or "")
+ rdepends += bb.utils.explode_deps(bb.data.getVar("RDEPENDS_%s" % pn, the_data, True) or "")
else:
packages = (bb.data.getVar('PACKAGES', the_data, 1).split() or "")
for package in packages:
diff --git a/openembedded/conf/bitbake.conf b/openembedded/conf/bitbake.conf
index 89ab4ff924..1b567fe521 100644
--- a/openembedded/conf/bitbake.conf
+++ b/openembedded/conf/bitbake.conf
@@ -72,7 +72,7 @@ DATETIME = "${DATE}${TIME}"
# python-native should be here but python relies on building
# its own in staging
-ASSUME_PROVIDED = "cvs-native svn-native"
+ASSUME_PROVIDED = "cvs-native svn-native bzip2-native patch-native diffstat-native"
##################################################################
# Package default variables.
diff --git a/openembedded/packages/quilt/quilt-native_0.42.bb b/openembedded/packages/quilt/quilt-native_0.42.bb
index ad3834ea21..6c54c476ce 100644
--- a/openembedded/packages/quilt/quilt-native_0.42.bb
+++ b/openembedded/packages/quilt/quilt-native_0.42.bb
@@ -14,6 +14,9 @@ PATCHCLEANCMD = ""
PATCHCMD = "num='%s'; name='%s'; file='%s'; patch -p "$num" -i "$file""
EXTRA_OECONF = "--disable-nls"
+#RDEPENDS_${PN} = "patch-native diffstat-native bzip2-native"
+RDEPENDS_${PN} = ""
+
do_configure () {
chmod 755 configure
oe_runconf