summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/minicom/minicom-2.1/configure.patch25
-rw-r--r--meta-extras/packages/minicom/minicom-2.1/gcc4-scope.patch44
-rw-r--r--meta-extras/packages/minicom/minicom_2.1.bb12
3 files changed, 0 insertions, 81 deletions
diff --git a/meta-extras/packages/minicom/minicom-2.1/configure.patch b/meta-extras/packages/minicom/minicom-2.1/configure.patch
deleted file mode 100644
index 4db47fb3d8..0000000000
--- a/meta-extras/packages/minicom/minicom-2.1/configure.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Index: minicom-2.1/configure.in
-===================================================================
---- minicom-2.1.orig/configure.in 2003-04-29 21:08:25.000000000 +0000
-+++ minicom-2.1/configure.in 2005-07-04 19:03:32.000000000 +0000
-@@ -231,9 +231,9 @@
- AC_HEADER_STAT
- AC_HEADER_TIME
-
--AM_SYS_POSIX_TERMIOS
-+AC_SYS_POSIX_TERMIOS
- AM_HEADER_TIOCGWINSZ_NEEDS_SYS_IOCTL
--if test $am_cv_sys_posix_termios = yes; then
-+if test $ac_cv_sys_posix_termios = yes; then
- AC_DEFINE(POSIX_TERMIOS)
- fi
-
-@@ -253,7 +253,7 @@
-
- dnl Checks for library functions.
- AC_TYPE_SIGNAL
--AM_FUNC_ERROR_AT_LINE
-+AC_FUNC_ERROR_AT_LINE
- AC_FUNC_CLOSEDIR_VOID
- AM_WITH_DMALLOC
- AC_CHECK_FUNCS(getcwd getwd strerror strstr vsnprintf vprintf)
diff --git a/meta-extras/packages/minicom/minicom-2.1/gcc4-scope.patch b/meta-extras/packages/minicom/minicom-2.1/gcc4-scope.patch
deleted file mode 100644
index 5bd47bd354..0000000000
--- a/meta-extras/packages/minicom/minicom-2.1/gcc4-scope.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- minicom-2.1/src/window.c.orig 2006-06-14 17:49:53.000000000 +0200
-+++ minicom-2.1/src/window.c 2006-06-14 17:50:14.000000000 +0200
-@@ -62,7 +62,7 @@
- static char *CS, *SF, *SR, *VB, *BL;
- static char *VE, *VI, *KS, *KE;
- static char *CD, *CL, *IC, *DC;
--static char *BC, *CR, *NL;
-+static char *mcBC, *CR, *NL;
- #if ST_LINE
- static char *TS, *FS, *DS;
- #endif
-@@ -322,8 +322,8 @@
- else if (NL != CNULL && x == 0 && x == curx && y == cury + 1)
- outstr(NL);
- #endif
-- else if (BC != CNULL && y == cury && x == curx - 1)
-- outstr(BC);
-+ else if (mcBC != CNULL && y == cury && x == curx - 1)
-+ outstr(mcBC);
- else
- outstr(tgoto(CM, x, y));
- curx = x;
-@@ -1918,7 +1918,7 @@
- CL = tgetstr("cl", &_tptr);
- IC = tgetstr("ic", &_tptr);
- DC = tgetstr("dc", &_tptr);
-- BC = tgetstr("bc", &_tptr);
-+ mcBC = tgetstr("bc", &_tptr);
- CR = tgetstr("cr", &_tptr);
- NL = tgetstr("nl", &_tptr);
- AC = tgetstr("ac", &_tptr);
-@@ -1967,10 +1967,10 @@
- _has_am = tgetflag("am");
- _mv_standout = tgetflag("ms");
- if (tgetflag("bs")) {
-- if (BC == CNULL) BC = "\b";
-+ if (mcBC == CNULL) mcBC = "\b";
- }
- else
-- BC = CNULL;
-+ mcBC = CNULL;
-
- /* Special IBM box-drawing characters */
- D_UL = 201;
diff --git a/meta-extras/packages/minicom/minicom_2.1.bb b/meta-extras/packages/minicom/minicom_2.1.bb
deleted file mode 100644
index c4a1c3018a..0000000000
--- a/meta-extras/packages/minicom/minicom_2.1.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-SECTION = "console/network"
-DEPENDS = "ncurses"
-LICENSE = "GPL"
-SRC_URI = "http://alioth.debian.org/download.php/123/minicom-${PV}.tar.gz \
- file://configure.patch;patch=1 \
- file://gcc4-scope.patch;patch=1"
-
-inherit autotools gettext
-
-do_install() {
- for d in doc extras man intl lib src; do make -C $d DESTDIR=${D} install; done
-}